Missing Add Remote option in the Project Interpreter configuration

I can see the old remote interpreters marked as invalid and the gear button menu on the right no longer has the Add Remote option. My Deployment options are still there with default sftp settings. running Pycharm 2016.1.2. Anyone having the same problem?

3 comments
Comment actions Permalink

ok, problem solved.

  1. export settings (I already had my old settings)
  2. remove settings dir (~/.PyCharm2016.1)
  3. restart pycharm without importing settings
  4. import settings
  5. restart PyCharm
  6. :tada: it works!
1
Comment actions Permalink

Had to reconfigure all the remote interpreters, but it did resolve the issue.

Thanks Rafal!

0

Please sign in to leave a comment.