Cannot run rake task RubyMine 7.1 [SOLVED]

I am currently running RubyMine 7.1 on Mac OSX Yosemite using rails 4.2.4 with Ruby 2.2.1 using RVM. I am just starting to use RubyMine (coming from sublime text and the command line) and I am trying to run a simple rake task from the interface built into RubyMine and it is not showing the list of rake tasks available.

When I type * or db:create or anything into the rake task window nothing pops up and all text just turns red. If I leave it blank it just stays there saying "Loading rake tasks...".

Do I need to populate the available rake tasks some how?

7 comments
Comment actions Permalink

You should wait until rake tasks are loaded. How long did you wait?

0
Comment actions Permalink

I have waited 10 minutes.

0
Comment actions Permalink

If you open Gemfile, would you see any warnings?

0
Comment actions Permalink

I have no errors in the gemfile. Is there a plugin that deals with the rake tasks? or does it pull it from one of the gem files?



Attachment(s):
image.tiff
0
Comment actions Permalink

Gemfile looks ok. Could you provide logs. Instruction how to find log files here: https://intellij-support.jetbrains.com/hc/en-us/articles/206827517-Locating-IDE-log-files

0
Comment actions Permalink

I have tried to click reload rake tasks... and the screen is stuck loading (see attached).



Attachment(s):
image.tiff
0
Comment actions Permalink

I figured it out kind of... I downloaded the rubymine for yosemite that has the bundled jdk from the jetbrians website and everything seems to be working great now (its quite a bit faster as well).

Not sure what is wrong with the other version.

Thanks for your help.

0

Please sign in to leave a comment.