Change default encoding for Rubymine

I have RubyMine 7.1.
Every time I create a new file, the file has encoding "windows-1251". I want it to be "UTF-8".
I have IDE Encoding set to "UTF-8" in Settings |  Appearance&Behavior | System Settings , but it always sets "windows-1251" for newly created files.

How to fix this?

4 comments
Comment actions Permalink

Hi,

the only setting we have is the one you have used (at least the only one I'm aware of ;) )
How do you create new files?  Is it File|New or something else?

Regards, Oleg.

0
Comment actions Permalink

I tried two ways of creating a new File
- File | New .. from top menu
- New | File from context menu on a folder in Project Structure.

It works fine with previous version of Rubymine.

I will try to install a clean version of Rubymine 7.1 or 7.0.

0
Comment actions Permalink

the same story with the newly installed Rubymine 7.1.1.

I noticed one thing in Settings:
it shows UTF-8,
when I change it to Windows-1251 from the list, Apply button is still disabled, which means windows-1251 is the current encoding,
when I select another encoding from the list (say, windows-1255), then Apply button can be clicked.
Looks like encoding is really = windows-1251, not UTF-8, in some Rubymine settings.
or Rubymine takes system settings from Windows.

Where to look files with Rubymine settings?

0
Comment actions Permalink

it looks like a bug for me, could you please file one in our tracker (https://youtrack.jetbrains.com/issues/RUBY)

Thanks in advance, Oleg.

0

Please sign in to leave a comment.