PHPStorm tree view indentation spacing

I changed the font in the editor to set a smaller size I am more comfortable reading.  However the file tree displayed in the project view does not adjust the spacing - it seems to be set to a fixed width assuming the default text size - which means I have to set that window much wider then should be needed just in order to see the filenames in deeply nested folders.

 

Is there a setting somewhere to adjust the indentation for the file tree?

1 comment
Comment actions Permalink

Hi there,

AFAIK Project View should not be affected by Editor's font (except VCS status colors). I think you may need to use different font for the actual GUI Theme -- "Settings/Preferences | Appearance & Behaviour | Appearance --> Override default fonts...".

Another note: gaps (paddings/etc) are usually tied to the GUI Theme. For example: I'm on Windows and I'm using "Windows" theme because any other theme will simply use more space between rows displaying project structure while Windows one is much more compact. Therefore it's possible that adjusting the font size as mentioned earlier may not help much here...

0

Please sign in to leave a comment.