22 comments
Comment actions Permalink

Hi,

what version of RubyMine are you using?

Regards, Oleg.

0
Comment actions Permalink

Thank you for your reply.

I'm using "RubyMine 7.0.1 Build 139.631" and "Vagrant 1.6.5" on OSX Yosemite(10.10.1).

0
Comment actions Permalink

Hi,

could you please delete the sdk, add it again and provide (attach) RubyMine's logs (Help|Show Log in ...)

Thanks in advance, Oleg.

0
Comment actions Permalink

could you please delete the sdk, add it again and provide (attach) RubyMine's logs (Help|Show Log in ...)



I have attached a log. please take a look.

Regards.

Attachment(s):
idea.log.zip
0
Comment actions Permalink

Could you also provide ~/Library/Preferences/RubyMine70/options/jdk.table.xml or (at least ) the node for the problematic sdk.

Regards, Oleg

0
Comment actions Permalink

jdk.table.xml

    <jdk version="2">       <name value="Remote:jruby-1.7.12-p392" />       <type value="JRUBY_SDK" />       <version value="ver.1.7.12 (1.9.3p392) 643e292 on OpenJDK 64-Bit Server VM 1.7.0_65-b32 p392" />       <homePath value="vagrant:///Users/user/Documents/RubymineProjects/project/home/vagrant/.rbenv/versions/jruby-1.7.12/bin/jruby" />       <roots>         <classPath>           <root type="composite">             <root type="simple" url="file://$APPLICATION_HOME_DIR$/rubystubs19" />           </root>         </classPath>         <sourcePath>           <root type="composite">             <root type="simple" url="file://$APPLICATION_HOME_DIR$/rubystubs19" />           </root>         </sourcePath>       </roots>       <additional LANGUAGE_LEVEL="ruby19" IS_RVM_SDK="false" RVM_IGNORE_GLOBAL="false" GEMS_BIN_DIR_PATH="$USER_HOME$/Library/Caches/RubyMine70/ruby_stubs/-405109559/-848000119" DATA-VERSION="2" VAGRANT_FOLDER="$USER_HOME$/Documents/RubymineProjects/project" INTERPRETER_PATH="/home/vagrant/.rbenv/versions/jruby-1.7.12/bin/jruby" HELPERS_PATH="/home/vagrant/.rubymine_helpers" INITIALIZED="false" VALID="true">         <GEMS_ROOTS_URLS_ROOT GEMS_ROOTS_URL="file://$USER_HOME$/Library/Caches/RubyMine70/ruby_stubs/-405109559/1617006690/gems" />         <GEMS_ROOTS_URLS_ROOT GEMS_ROOTS_URL="file://$USER_HOME$/Library/Caches/RubyMine70/ruby_stubs/-405109559/1617006690/bundler/gems" />         <GEMS_ROOTS_URLS_ROOT GEMS_ROOTS_URL="file://$USER_HOME$/Library/Caches/RubyMine70/ruby_stubs/-405109559/183558435/gems" />         <GEMS_ROOTS_URLS_ROOT GEMS_ROOTS_URL="file://$USER_HOME$/Library/Caches/RubyMine70/ruby_stubs/-405109559/183558435/bundler/gems" />         <PathMappingSettings>           <option name="pathMappings">             <list>               <mapping local-root="$USER_HOME$/Library/Caches/RubyMine70/ruby_stubs/-405109559/-848000119" remote-root="/home/vagrant/.rbenv/versions/jruby-1.7.12/bin" />               <mapping local-root="$USER_HOME$/Library/Caches/RubyMine70/ruby_stubs/-405109559/1617006690/bin" remote-root="/home/vagrant/.gem/jruby/1.9/bin" />               <mapping local-root="$USER_HOME$/Library/Caches/RubyMine70/ruby_stubs/-405109559/1617006690/gems" remote-root="/home/vagrant/.gem/jruby/1.9/gems" />               <mapping local-root="$USER_HOME$/Library/Caches/RubyMine70/ruby_stubs/-405109559/1617006690/specifications" remote-root="/home/vagrant/.gem/jruby/1.9/specifications" />               <mapping local-root="$USER_HOME$/Library/Caches/RubyMine70/ruby_stubs/-405109559/1617006690/bundler" remote-root="/home/vagrant/.gem/jruby/1.9/bundler" />               <mapping local-root="$USER_HOME$/Library/Caches/RubyMine70/ruby_stubs/-405109559/183558435/bin" remote-root="/home/vagrant/.rbenv/versions/jruby-1.7.12/lib/ruby/gems/shared/bin" />               <mapping local-root="$USER_HOME$/Library/Caches/RubyMine70/ruby_stubs/-405109559/183558435/gems" remote-root="/home/vagrant/.rbenv/versions/jruby-1.7.12/lib/ruby/gems/shared/gems" />               <mapping local-root="$USER_HOME$/Library/Caches/RubyMine70/ruby_stubs/-405109559/183558435/specifications" remote-root="/home/vagrant/.rbenv/versions/jruby-1.7.12/lib/ruby/gems/shared/specifications" />               <mapping local-root="$USER_HOME$/Library/Caches/RubyMine70/ruby_stubs/-405109559/183558435/bundler" remote-root="/home/vagrant/.rbenv/versions/jruby-1.7.12/lib/ruby/gems/shared/bundler" />             </list>           </option>         </PathMappingSettings>       </additional>     </jdk>


Best regards.

0
Comment actions Permalink

Since I see nothing special I will try to reproduce the problem locally and let you know about the results.

Regards, Oleg.

0
Comment actions Permalink

I've performed the following experiment:
created a new vagrant box (Ubuntu), downloaded .tar.gz for jruby 1.7.17, unpack it, created a remote sdk, specifying "<jruby home>/bin/jruby" as interpreter.
And I can select any of language levels (1.8, 1.9. 2.0) for the sdk.

Perhaps the source of the problem is the way you have configured the sdk to use 2.0 by default?  What did you do?
Does RM work correctly if you remove these settings?

Regards, Oleg.

0
Comment actions Permalink

Hi

I have the same problem. I installed RM 7.0 on an Ubuntu server and I can only configure the language level as either 1.8 or 1.9 but not 2.0

2014-12-09  08:37:44,998 [ 0] INFO - #com.intellij.idea.Main -  ------------------------------------------------------ IDE STARTED  ------------------------------------------------------
2014-12-09  08:37:45,016 [ 18] INFO - #com.intellij.idea.Main - IDE: RubyMine (build  #RM-139.631, 01 Dec 2014 00:00)
2014-12-09 08:37:45,016 [ 18] INFO -  #com.intellij.idea.Main - OS: Linux (3.13.0-36-generic, amd64)
2014-12-09  08:37:45,016 [ 18] INFO - #com.intellij.idea.Main - JRE: 1.7.0_65-b32 (Oracle  Corporation)
2014-12-09 08:37:45,016 [ 18] INFO - #com.intellij.idea.Main -  JVM: 24.65-b04 (OpenJDK 64-Bit Server VM)
2014-12-09 08:37:45,019 [ 21] INFO  - #com.intellij.idea.Main - JVM Args: -Xms128m -Xmx512m -XX:MaxPermSize=250m -ea  -Dsun.io.useCanonCaches=false -Djava.net.preferIPv4Stack=true  -Djsse.enableSNIExtension=false -XX:+UseConcMarkSweepGC  -XX:SoftRefLRUPolicyMSPerMB=50 -Dawt.useSystemAAFontSettings=lcd  -Djb.vmOptionsFile=/home/hofkensj/RubyMine-7.0.1/bin/rubymine64.vmoptions  -XX:ErrorFile=/home/hofkensj/java_error_in_RUBYMINE_%p.log  -Xbootclasspath/a:/home/hofkensj/RubyMine-7.0.1/bin/../lib/boot.jar  -Didea.paths.selector=RubyMine70 -Didea.platform.prefix=Ruby  -Didea.no.jre.check=true -Djb.restart.code=88
2014-12-09 08:37:45,068 [ 70]  INFO - #com.intellij.idea.Main - JNA library loaded (64-bit) in 49  ms
2014-12-09 08:37:45,932 [ 934] INFO - llij.openapi.wm.impl.X11UiUtil -  _NET protocol is not supported
2014-12-09 08:37:45,934 [ 936] INFO -  .intellij.idea.IdeaApplication - WM detected: null
2014-12-09 08:37:46,582 [  1584] INFO - llij.ide.plugins.PluginManager - Cannot find optional descriptor  uml-properties-support.xml
2014-12-09 08:37:46,594 [ 1596] INFO -  llij.ide.plugins.PluginManager - Cannot find optional descriptor  uml-java-support.xml
2014-12-09 08:37:47,593 [ 2595] INFO -  llij.ide.plugins.PluginManager - 40 plugins initialized in 1387 ms
2014-12-09  08:37:47,594 [ 2596] INFO - llij.ide.plugins.PluginManager - Loaded bundled  plugins: CSS Support, CVS Integration (11), CoffeeScript (2.0), Database Tools  and SQL (1.0), EditorConfig (1.0), Gherkin (999.999), Git Integration (8.1),  GitHub, HAML, HTML Tools (2.0), IDEA CORE, IntelliLang (8.0), JavaScript  Debugger (1.0), JavaScript Intention Power Pack (0.9.4), JavaScript Support  (1.0), LESS support, Perforce Integration (2.0), Puppet Support (VERSION), REST  Client, Remote Hosts Access (0.1), Ruby CSS Support Integration, Ruby Code  Coverage, Ruby Cucumber support, Ruby Database Support Integration, Ruby HAML  Support Integration, Ruby JavaScript Debugger Integration, Ruby Remote SDK  Support (0.1), Ruby Slim Support Integration, Ruby UML Support Integration, SASS  support, SSH Remote Run (0.1), Slim (VERSION), Stylus support (999.999),  Subversion Integration (1.1), Task Management (1.0), Terminal (0.1), TextMate  bundles support (VERSION), UML Support (1.0), Vagrant (0.4), hg4idea  (10.0)
2014-12-09 08:37:48,159 [ 3161] INFO - ellij.util.io.PagedFileStorage  - lower=100; upper=200; buffer=10; max=498008064
2014-12-09 08:37:48,261 [  3263] INFO - api.vfs.impl.local.FileWatcher - Starting file watcher:  /data/home/hofkensj/RubyMine-7.0.1/bin/fsnotifier64
2014-12-09 08:37:48,272 [  3274] INFO - api.vfs.impl.local.FileWatcher - Native file watcher is  operational.
2014-12-09 08:37:49,015 [ 4017] INFO -  lij.diagnostic.DebugLogManager - Set DEBUG for the following categories:  []
2014-12-09 08:37:50,277 [ 5279] INFO - pl.stores.ApplicationStoreImpl - 82  application components initialized in 2635 ms
2014-12-09 08:37:50,291 [ 5293]  INFO - .intellij.idea.IdeaApplication - App initialization took 9984  ms
2014-12-09 08:37:50,336 [ 5338] WARN - ateSettings.impl.UpdateChecker -  Connection failed. Please check your network connection and try  again.
2014-12-09 08:37:50,507 [ 5509] INFO - om.intellij.util.ProfilingUtil  - Profiling agent is not enabled. Add -agentlib:yjpagent to idea.vmoptions if  necessary to profile IDEA.
2014-12-09 08:37:52,062 [ 7064] INFO -  management.pik.PikSdkRefresher - Refreshing sdks
2014-12-09 08:37:52,062 [  7064] INFO - management.pik.PikSdkRefresher - pik isn't supported by  OS
2014-12-09 08:37:52,068 [ 7070] INFO - gement.rbenv.RbenvSdkRefresher -  Refreshing sdks
2014-12-09 08:37:52,068 [ 7070] INFO -  gement.rbenv.RbenvSdkRefresher - rubies folder doesn't exist
2014-12-09  08:37:52,283 [ 7285] INFO - ellij.project.impl.ProjectImpl - 119 project  components initialized in 1039 ms
2014-12-09 08:37:52,396 [ 7398] INFO -  le.impl.ModuleManagerComponent - 1 module(s) loaded in 113 ms
2014-12-09  08:37:52,788 [ 7790] INFO - management.rvm.RvmSdkRefresher - Extracting ruby and  gemset from /home/hofkensj/repo/trunk/.rvmrc
2014-12-09 08:37:52,864 [ 7866]  INFO - roject.impl.ProjectManagerImpl - FW/roots waiting started
2014-12-09  08:37:53,023 [ 8025] INFO - rains.ide.BuiltInServerManager - built-in server  started, port 63342
2014-12-09 08:37:53,261 [ 8263] INFO -  roject.impl.ProjectManagerImpl - FW/roots waiting finished
2014-12-09  08:37:57,734 [ 12736] INFO - nject.config.XPathSupportProxy - XPath Support is  not available
2014-12-09 08:37:58,478 [ 13480] INFO -  tor.impl.FileEditorManagerImpl - Project opening took 7281 ms
2014-12-09  08:37:58,844 [ 13846] INFO - indexing.UnindexedFilesUpdater - Indexable files  iterated in 2379 ms
2014-12-09 08:37:58,844 [ 13846] INFO -  indexing.UnindexedFilesUpdater - Unindexed files update started: 739 files to  update
2014-12-09 08:38:03,430 [ 18432] INFO - indexing.UnindexedFilesUpdater  - Unindexed files update done in 4586 ms
2014-12-09 08:38:03,490 [ 18492]  INFO - s.ruby.ruby.run.AbstractRunner - Executing non-rvm sdk on system with rvm  installed thus GEM_PATH and GEM_HOME will be unset
2014-12-09 08:38:03,492 [  18494] INFO - .ruby.ruby.run.RubyCommandLine - Executing [/usr/bin/jruby --1.9  -e $stdout.sync=true;$stderr.sync=true;load($0=ARGV.shift) /usr/bin/gem  environment gempath], working dir =[/usr/bin]
2014-12-09 08:38:03,564 [  18566] INFO - dvertisement.PluginsAdvertiser -  plugins.jetbrains.com
java.net.UnknownHostException:  plugins.jetbrains.com
at  java.net.AbstractPlainSocketImpl.connect(AbstractPlainSocketImpl.java:178)
at  java.net.SocksSocketImpl.connect(SocksSocketImpl.java:392)
at  java.net.Socket.connect(Socket.java:579)
at  sun.net.NetworkClient.doConnect(NetworkClient.java:175)
at sun.net.www.http.HttpClient.openServer(HttpClient.java:432)
at  sun.net.www.http.HttpClient.openServer(HttpClient.java:527)
at  sun.net.www.http.HttpClient.<init>(HttpClient.java:211)
at  sun.net.www.http.HttpClient.New(HttpClient.java:308)
at  sun.net.www.http.HttpClient.New(HttpClient.java:326)
at  sun.net.www.protocol.http.HttpURLConnection.getNewHttpClient(HttpURLConnection.java:996)
at  sun.net.www.protocol.http.HttpURLConnection.plainConnect(HttpURLConnection.java:975)
at  sun.net.www.protocol.http.HttpURLConnection.connect(HttpURLConnection.java:850)
at  sun.net.www.protocol.http.HttpURLConnection.getInputStream(HttpURLConnection.java:1300)
at  java.net.HttpURLConnection.getResponseCode(HttpURLConnection.java:468)
at  com.intellij.util.HttpRequests.a(HttpRequests.java:144)
at  com.intellij.util.HttpRequests.a(HttpRequests.java:106)
at  com.intellij.util.HttpRequests.access$000(HttpRequests.java:34)
at  com.intellij.util.HttpRequests$HttpRequestBuilder.get(HttpRequests.java:74)
at  com.intellij.ide.plugins.RepositoryHelper.loadPluginsFromRepository(RepositoryHelper.java:76)
at  com.intellij.ide.plugins.RepositoryHelper.loadPluginsFromRepository(RepositoryHelper.java:51)
at  com.intellij.openapi.updateSettings.impl.pluginsAdvertisement.PluginsAdvertiser$2$1.run(PluginsAdvertiser.java:260)
at  com.intellij.openapi.application.impl.ApplicationImpl$8.run(ApplicationImpl.java:405)
at  java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:471)
at  java.util.concurrent.FutureTask.run(FutureTask.java:262)
at  java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)
at  java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
at  java.lang.Thread.run(Thread.java:745)
at  org.jetbrains.ide.PooledThreadExecutor$1$1.run(PooledThreadExecutor.java:56)
2014-12-09  08:38:05,287 [ 20289] INFO - ellij.concurrency.JobScheduler - 50 ms execution  limit failed for:  com.intellij.openapi.progress.impl.ProgressManagerImpl$1@738fbc54<mailto:com.intellij.openapi.progress.impl.ProgressManagerImpl$1@738fbc54>;  elapsed time was 54ms
2014-12-09 08:38:07,893 [ 22895] INFO -  s.ruby.ruby.run.AbstractRunner - Executing non-rvm sdk on system with rvm  installed thus GEM_PATH and GEM_HOME will be unset
2014-12-09 08:38:07,894 [  22896] INFO - .ruby.ruby.run.RubyCommandLine - Executing [/usr/bin/jruby --1.9  --disable-gems -e "puts $:"], working dir =[null]
2014-12-09 08:38:09,471 [  24473] INFO - e.GemRequirementsChangeWatcher - Initial scan  started
2014-12-09 08:38:13,329 [ 28331] INFO -  e.GemRequirementsChangeWatcher - Initial scan took: 3857 ms
2014-12-09  08:38:20,269 [ 35271] INFO - indexing.UnindexedFilesUpdater - Indexable files  iterated in 26 ms
2014-12-09 08:38:20,581 [ 35583] WARN -  e.GemRequirementsChangeWatcher - No Sdk selected for Module:  'trunk'
2014-12-09 08:38:23,416 [ 38418] INFO -  indexing.UnindexedFilesUpdater - Indexable files iterated in 51 ms
2014-12-09  08:38:23,416 [ 38418] INFO - indexing.UnindexedFilesUpdater - Unindexed files  update started: 5 files to update
2014-12-09 08:38:23,506 [ 38508] INFO -  indexing.UnindexedFilesUpdater - Unindexed files update done in 90  ms
2014-12-09 08:38:23,611 [ 38613] INFO - ellij.project.impl.ProjectImpl -  16 project components initialized in 10 ms
2014-12-09 08:38:23,611 [ 38613]  INFO - le.impl.ModuleManagerComponent - 0 module(s) loaded in 0 ms
2014-12-09  08:38:24,396 [ 39398] WARN - e.GemRequirementsChangeWatcher - No Sdk selected  for Module: 'trunk'
2014-12-09 08:38:49,425 [ 64427] INFO -  .ruby.ruby.run.RubyCommandLine - Executing [/usr/bin/jruby -e "print  JRUBY_VERSION"], working dir =[null]
2014-12-09 08:38:51,380 [ 66382] INFO -  .ruby.ruby.run.RubyCommandLine - Executing [/usr/bin/jruby -e  "print(defined?(RUBY_PATCHLEVEL) ? RUBY_PATCHLEVEL : 0)"], working dir  =[null]
2014-12-09 08:38:53,371 [ 68373] INFO -  .ruby.ruby.run.RubyCommandLine - Executing [/usr/bin/jruby -v], working dir  =[null]
2014-12-09 08:38:53,567 [ 68569] INFO -  .ruby.ruby.run.RubyCommandLine - Executing [/usr/bin/jruby -e  "print(defined?(RUBY_PATCHLEVEL) ? RUBY_PATCHLEVEL : 0)"], working dir  =[null]
2014-12-09 08:38:55,557 [ 70559] INFO -  .ruby.ruby.run.RubyCommandLine - Executing [/usr/bin/jruby -v], working dir  =[null]
2014-12-09 08:38:55,725 [ 70727] INFO -  .ruby.ruby.run.RubyCommandLine - Executing [/usr/bin/jruby -e  "print(defined?(RUBY_PATCHLEVEL) ? RUBY_PATCHLEVEL : 0)"], working dir  =[null]
2014-12-09 08:38:57,717 [ 72719] INFO -  .ruby.ruby.run.RubyCommandLine - Executing [/usr/bin/jruby -v], working dir  =[null]
2014-12-09 08:38:57,884 [ 72886] INFO -  .ruby.ruby.run.RubyCommandLine - Executing [/usr/bin/jruby -e  "print(defined?(RUBY_PATCHLEVEL) ? RUBY_PATCHLEVEL : 0)"], working dir  =[null]
2014-12-09 08:38:59,868 [ 74870] INFO -  s.ruby.ruby.run.AbstractRunner - Executing non-rvm sdk on system with rvm  installed thus GEM_PATH and GEM_HOME will be unset
2014-12-09 08:38:59,869 [  74871] INFO - .ruby.ruby.run.RubyCommandLine - Executing [/usr/bin/jruby --2.0  -e "puts $:"], working dir =[null]
2014-12-09 08:39:01,905 [ 76907] INFO -  s.ruby.ruby.run.AbstractRunner - Executing non-rvm sdk on system with rvm  installed thus GEM_PATH and GEM_HOME will be unset
2014-12-09 08:39:01,905 [  76907] INFO - .ruby.ruby.run.RubyCommandLine - Executing [/usr/bin/jruby --2.0  -e $stdout.sync=true;$stderr.sync=true;load($0=ARGV.shift) /usr/bin/gem  environment gempath], working dir =[/usr/bin]
2014-12-09 08:39:02,197 [  77199] INFO - indexing.UnindexedFilesUpdater - Indexable files iterated in 47  ms
2014-12-09 08:39:02,197 [ 77199] INFO - indexing.UnindexedFilesUpdater -  Unindexed files update started: 2 files to update
2014-12-09 08:39:02,200 [  77202] INFO - indexing.UnindexedFilesUpdater - Unindexed files update done in 3  ms
2014-12-09 08:39:05,323 [ 80325] INFO - s.ruby.ruby.run.AbstractRunner -  Executing non-rvm sdk on system with rvm installed thus GEM_PATH and GEM_HOME  will be unset
2014-12-09 08:39:05,324 [ 80326] INFO -  .ruby.ruby.run.RubyCommandLine - Executing [/usr/bin/jruby --2.0 --disable-gems  -e "puts $:"], working dir =[null]
2014-12-09 08:39:06,833 [ 81835] INFO -  indexing.UnindexedFilesUpdater - Indexable files iterated in 16 ms
2014-12-09  08:39:12,706 [ 87708] INFO - s.ruby.ruby.run.AbstractRunner - Executing non-rvm  sdk on system with rvm installed thus GEM_PATH and GEM_HOME will be  unset
2014-12-09 08:39:12,706 [ 87708] INFO - .ruby.ruby.run.RubyCommandLine  - Executing [/usr/bin/jruby --1.9 -e  $stdout.sync=true;$stderr.sync=true;load($0=ARGV.shift) /usr/bin/gem environment  gempath], working dir =[/usr/bin]
2014-12-09 08:39:15,987 [ 90989] INFO -  s.ruby.ruby.run.AbstractRunner - Executing non-rvm sdk on system with rvm  installed thus GEM_PATH and GEM_HOME will be unset
2014-12-09 08:39:15,988 [  90990] INFO - .ruby.ruby.run.RubyCommandLine - Executing [/usr/bin/jruby --1.9  --disable-gems -e "puts $:"], working dir =[null]
2014-12-09 08:39:17,407 [  92409] INFO - indexing.UnindexedFilesUpdater - Indexable files iterated in 21  ms
2014-12-09 08:39:25,446 [ 100448] INFO - indexing.UnindexedFilesUpdater -  Indexable files iterated in 16 ms
2014-12-09 08:39:25,446 [ 100448] INFO -  indexing.UnindexedFilesUpdater - Unindexed files update started: 5 files to  update
2014-12-09 08:39:25,538 [ 100540] INFO -  indexing.UnindexedFilesUpdater - Unindexed files update done in 92 ms

<application>
<component  name="ProjectJdkTable">
<jdk version="2">
<name  value="jruby-1.7.13-p195" />
<type value="JRUBY_SDK"  />
<version value="ver.1.7.13 (2.0.0p195) 43f133c on OpenJDK 64-Bit  Server VM 1.7.0_65-b32 p195" />
<homePath value="/usr/bin/jruby"  />
<roots>
<classPath>
<root  type="composite">
<root type="simple"  url="file://$APPLICATION_HOME_DIR$/rubystubs20" />
<root type="simple"  url="file:///data/jruby-1.7.13/lib/ruby/shared" />
<root type="simple"  url="file:///data/jruby-1.7.13/lib/ruby/2.0" />
<root type="simple"  url="file://$APPLICATION_HOME_DIR$/rubystubs20"  />
</root>
</classPath>
<sourcePath>
<root  type="composite"  />
</sourcePath>
</roots>
<additional  LANGUAGE_LEVEL="ruby20" IS_RVM_SDK="false" RVM_IGNORE_GLOBAL="false"  GEMS_BIN_DIR_PATH="/usr/bin"  />
</jdk>
</component>
</application>
________________________________  


I'm using jruby-1.7.13-p195 as the SDK.

I can run this locally on my Win XP PC (RM 7.0 and jruby 1.7.13 (2.0.0p195)

0
Comment actions Permalink

How do you configured jruby to use 2.0 as default language level?

Regards, Oleg.

0
Comment actions Permalink

Hi Oleg

I have created a .jrubyrc file in my Ubuntu home directory

> more .jrubyrc
compat.version=2.0


And in addition to that I have configured

> more :~/RubyMine-7.0.1/bin/idea.properties
# Use ${idea.home} macro to specify location relative to IDE installation home.
# Use ${xxx} where xxx is any Java property (including defined in previous lines of this file) to refer to its value.
# Note for Windows users: please make sure you're using forward slashes (e.g. c:/idea/system).

#---------------------------------------------------------------------
# Uncomment this option if you want to customize path to IDE config folder. Make sure you're using forward slashes.
#---------------------------------------------------------------------
idea.config.path=${user.home}/.RubyMine/config

#---------------------------------------------------------------------
# Uncomment this option if you want to customize path to IDE system folder. Make sure you're using forward slashes.
#---------------------------------------------------------------------
idea.system.path=${user.home}/.RubyMine/system


I have manually changed ${user.home}/.RubyMine/config/jdk.table.xml

<application>
  <component name="ProjectJdkTable">
    <jdk version="2">
      <name value="jruby-1.7.13-p195" />
      <type value="JRUBY_SDK" />
      <version value="ver.1.7.13 (2.0.0p195) 43f133c on OpenJDK 64-Bit Server VM 1.7.0_65-b32 p195" />
      <homePath value="/usr/bin/jruby" />
      <roots>
        <classPath>
          <root type="composite">
            <root type="simple" url="file://$APPLICATION_HOME_DIR$/rubystubs20" />
            <root type="simple" url="file:///data/jruby-1.7.13/lib/ruby/shared" />
            <root type="simple" url="file:///data/jruby-1.7.13/lib/ruby/2.0" />
            <root type="simple" url="file://$APPLICATION_HOME_DIR$/rubystubs20" />
          </root>
        </classPath>
        <sourcePath>
          <root type="composite" />
        </sourcePath>
      </roots>
      <additional LANGUAGE_LEVEL="ruby20" IS_RVM_SDK="false" RVM_IGNORE_GLOBAL="false" GEMS_BIN_DIR_PATH="/usr/bin" />
    </jdk>
  </component>
</application>

0
Comment actions Permalink

Hi,

I've tried the experiment I've described in the comment with .jrubyrc containing "compat.version=2.0" in remote home, and everything works ok with RubyMine 7.0.1 (139.631)
Could you please perform the same experiment as I did to check if it reproduces the problem for you.

Regards, Oleg

0
Comment actions Permalink

Hi Oleg

It looks like that works.

It means that the SDK settings functionality in RubyMine doesn't work. It doesn't recognise all language levels applicable to the Jruby SDK.

But at least I have a manual workaround.

Thanks

Hans

0
Comment actions Permalink

Hi Hans,

it is great that you have found the workable solution for the problem, but to be able to fix this we need to reproduce it and
we are unable to do this :(  So it would be great if you could help us to reproduce it.

Regards, Oleg.

0
Comment actions Permalink

Hi Oleg

In our development area we run on a Ubuntu server:
Distributor ID: Ubuntu
Description:    Ubuntu 12.04.5 LTS
Release:        12.04
Codename:       precise


I have installed RubyMine on that server in /home/hofkensj/RubyMine-7.0.1

Jruby is installed on that server in /data/jruby-1.7.13
jruby 1.7.13 (2.0.0p195) 2014-06-24 43f133c on OpenJDK 64-Bit Server VM 1.7.0_65-b32 [linux-amd64]

When I start RubyMine and go to Settings>languages and Frameworks>Ruby SDK and Gems and select /data/jruby-1.7.13/bin/jruby

It will load all the gems but it will only allow language level 1.8 & 1.9 to be selected not 2.0.

If you need more info just let me know.

regards

Hans
0
Comment actions Permalink

Hi Hans,

so in your case this is not a remote sdk, but a local one?  Am I right?
If so, is it insalled using rbenv, rvm, or just plain installation?  If the latter what is the source from which you are installing it (which package)?
What if you unpack jruby downloaded from jruby.org into your home and create sdk from it.  Does RubyMine allow 2.0 language level for it or not?

Regards, Oleg.

0
Comment actions Permalink

Hi Oleg

I have experimented with both local and remote and it doesn't make any difference.

But currently it is local.

I'll experiment with installing a local version of jruby and see what happens.

Hans

0
Comment actions Permalink

Oleg

I have installed a local jruby version in my home environment and told Rubymine to use it, but still only language levels 1.8 and 1.9 can be selected.

Hans

0
Comment actions Permalink

Could you please provide part of jdk.table.xml which describes the local jruby sdk for which we can not change language level.

Regards, Oleg.

0
Comment actions Permalink

<application>
  <component name="ProjectJdkTable">
    <jdk version="2">
      <name value="jruby-1.7.13-p195" />
      <type value="JRUBY_SDK" />
      <version value="ver.1.7.13 (2.0.0p195) 43f133c on OpenJDK 64-Bit Server VM 1.7.0_65-b32 p195" />
      <homePath value="/usr/bin/jruby" />
      <roots>
        <classPath>
          <root type="composite">
            <root type="simple" url="file://$APPLICATION_HOME_DIR$/rubystubs20" />
            <root type="simple" url="file:///data/jruby-1.7.13/lib/ruby/shared" />
            <root type="simple" url="file:///data/jruby-1.7.13/lib/ruby/2.0" />
            <root type="simple" url="file:///data/jruby-1.7.13/lib/ruby/1.9" />
            <root type="simple" url="file://$APPLICATION_HOME_DIR$/rubystubs20" />
          </root>
        </classPath>
        <sourcePath>
          <root type="composite" />
        </sourcePath>
      </roots>
      <additional LANGUAGE_LEVEL="ruby20" IS_RVM_SDK="false" RVM_IGNORE_GLOBAL="false" GEMS_BIN_DIR_PATH="/usr/bin" />
    </jdk>
  </component>
</application>

0
Comment actions Permalink

I think I have (finally) realised what is the cause of the problem and why I was unable to reproduce it :)
It looks like you are using OpenJDK for jruby while I'm using OracleJDK.
And it looks like our code incorrectly handles version which is returned in your case.

So, I've created bug (https://youtrack.jetbrains.com/issue/RUBY-16109) about it.  Will fix it as soon as possible.
As a workaround you could use OracleJDK.

Regards, Oleg.

0
Comment actions Permalink

Hi Oleg

Thanks for your help.

I will use my current manual workaround and wait for a permanent solution.

Have a good Christmas

Hans

0

Please sign in to leave a comment.