Annoying Scrolling Problem with (Incorrect) Double Quoted String Warning

I just verified that this bug was introduced in version 7 as it does not happen in 6.3.

I could not scroll my schema.rb.  I was getting the "Double quoted string with no interpolation warning" whenever I moused over the scroll bar (I don't know if it's possible to even have schema.rb with single quouted strings, but then again I don't really care). This prevented me from being able to scroll using the scroll bar.  I had to turn off that warning in order to resolve the situation.

Although off topic, I cannot resist pointing out that the warning itself is invalid.  It is also incorrect where it implies that the style guide considers this a violation of style (essentially it says it is optional as long as you're consistent).  You should remove this warning or at least have it off by default.

5 comments
Comment actions Permalink

Hi,

you can disable this inspection (check contect menu for the warning)
As for scrolling I'm not sure what do you mean :(  Could you please make a small screencast which shows the problem.

Regards, Oleg.

0
Comment actions Permalink

Yea, I did disable it.  I said that in my post.  I just posted it because I think other people are going to run into this and it might save them some trouble.

By scrolling I mean the scrollbar that appears on the right gutter of the screen.  If I put my mouse cursor over it, normally I can click and drag the scrollbar up and down.  But when this bug is in effect the warning pops up when my cursor is over there and this apparently prevents scrolling.

This should be pretty easy to reproduce.  Just make sure this warning is on, load up a schema.rb that extends more than one screen, and mouse over to the scrollbar on the right and try to scroll.

I am on OSX 10.9.5 in case that matters.

0
Comment actions Permalink

Hi,

as for the inspection it is rather controvertial but the only way to make it discoverable is to enable it by default (imho we provide rather simple way to disable an inspection)

As for scrolling problem: unfortunately I was unable to reproduce the problem :( perhaps I'm doing sometihng wrong :(
What jdk are you using?  Perhaps a short screencast help me to undertand how to reproduce the problem.

Regards, Oleg.

0
Comment actions Permalink

I am using JRE 1.6.0_65.  I've reproduced it on two iMacs.

Your forum interface would not accept my screen cast file (which was smaller than 15MB).  So I give up.  Not sure how else to describe it.  Try to use the scrollbar thumb on a line that has a double quoted string with the warning turned on.  It's difficult to impossible.

0
Comment actions Permalink

Please file a bug in our tracker (https://youtrack.jetbrains.com/issues/RUBY) or send the information to our feedback (Help|Submit Feedback)

Thanks in advance, Oleg.

0

Please sign in to leave a comment.