Run/Debug test suddenly not an option in the context menu

Running latest Rubymine 6.

For some reason, sometimes (not always), I'll be working on code, click over to a test, Right click on a specific test to run that single specific text,


the context menu doesn't have the "Run/debug "blah""  as a test options.

I can tell because
1) the icon isn't a test icon
2) when I actually click the option, it tries to run the class and tries connecting to the chrome browser debug integration for somereason. Since I don't have that configured, it just sits and comes back with "Unable to connect to chrome debugger. Have you installed debugging extensions for chrome.

I'm guessing I've messed up some configuration somehow, but so far I've been unable to find anything that would seem to be related.

Any ideas?

Comment actions Permalink


it is hard to say what could go wrong from the description :(
What kind of tests are you using (Minitest, RSpec, Shoulda, something else)?
Also it might be helpful if you create a small test project which demonstrates the problem.

Regards, Oleg.

Comment actions Permalink

Thanks for the response.

I should have been more specific.

I'm using Test:Unit tests, functional, unit, and integration. All standard stuff, fixtures, helpers etc.

I've tried replicating in a small project and no luck.

It's actually been intermittant, which is the weird part.

IE, It's happened several times over the past few months where, suddenly, the right click context menu item to run a single test or all tests in a file, will show just the normal Run/Debug items and not the run/Debug tests.

It's as if an internal parser suddenly no longer realizes that the right click context is a  test and not just a normal method or class.

However, I'd continue on working, using the Environments drop down at the top to "run all tests" and eventually, the right click context would revert back to normal and I could run single tests again.

This time it's been a week though. I have no idea what I might have done to get it to recognize that when I right click in  a test, it knows I'm "In a test". That's the puzzling part.

My suspicion is that it has somethig to do with the configurations, but I've tried redoing them, changing options etc. and no luck so far.


Comment actions Permalink

Hi Darin,

I'm not sure what could cause of the problem.  But it would be helpful if next time you will have the problem you will send us RubyMine's logs (Help|Show Log in ...)
so we could look if there is any clues in it.  Also you could try to invalidate caches (File|Invalidate Caches) to see if this help.

Regards, Oleg.

Comment actions Permalink

I also have this problem.

The browser icons which usually appear when hovering in the top-right have suddenly stopped appearing, and shift+alt+f10 gives 0. Edit Configurations as the only option, even though I am in the html file I want to test.

Are there any updates on how to resolve this since 2014?

(this is for phpstorm not rubymine but I'm guessing the error is the same)

Comment actions Permalink

E271, the issue described here is slightly different. Also, a RubyMine thread isn't really the best place for discussing PhpStorm issues.

Please submit a ticket to HelpCenter answering these questions:

1. Did you modify the right click menu via Customize Menus and Toolbar?
2. What file types are affected?
3. Please right click one of the affected files and send us a screenshot of the menu (and file itself)


Please sign in to leave a comment.