Rubymine debugger tries to load javascript .map files...

Hey guys, so I just purchased RubyMine and I'm trying to squeeze all the functionality of it.

I heard that the js debugging capabilities are pretty cool, but I can't get it to work.

Everytime I run the project in debug mode the console shows an error for each of my javascript files like so

ActionController::RoutingError (No route matches [GET] "<my javascript file>"):

Basically it's trying to look for .map files that don't exist. How can I turn this off?

I can't debug because the server crashes with this error:
SystemStackError - stack level too deep


Do you try to debug CoffeeScript files in your Rails app?


nope, it's plain javascript files.

I searched my application and I don't have any coffeescript files.


It is normal behavior, see reasons

>> SystemStackError - stack level too deep
404 "not found" should not leads to server crash. It seems, server should be fixed.


how can I work around this issue?

it seems like an inconvenient default setting if my rails server crashes everytime I try to load a page (because of the non existing .map files) when debugging with rubymine

I don't think adding a bunch of unnecessary .map files is a convenient solution, either.
I've debugged javascript the traditional way (debugger; statement in code) without ever needing any sort of source maps, I purchased RubyMine because I thought it would make it more convenient for development and debugging, but it doesn't seem that way.

The person in the support ticket is also having issues with this default setting.



FYI, server is not crashing anymore, but the 404s make debugging VERY slow, i have to wait over a minute for each page to load

I think this is a functionality of the JetBrains chrome plugin because I've turned off souremaps in chrome settings, but chrome still asks for them.

I tried debugging with firefox and it DOES NOT request the .map files (which is good), but unfortunately, the breakpoints in my code are not working :/

this is very frustrating.


Please sign in to leave a comment.