RubyMine setup THIN server with --prefix tag

Hello,

I just started with RubyMine and like the idea to start the thin server directly out of the IDE.
But I need to use a specific adapter setting --prefix=/special.

In the terminal I simple type "thin -p 3000 -e development --prefix=/ror start".
But in RubyMine the system always and only use rails server <server> to start any web server.
This method can'T handle --prefix and I get a invalid option error in server.rb line 33.

So my question is:
How to use "thin start" directly or how to manage to make it work at all?

Meanwhile I can only run thin from any console outside of the IDE.

5 comments
Hi!  Did you get this resolved?  I am asking because I am trying to pass --max-cons to thin and I am getting the same error.  Thanks...
0

Hello,

no, the problem still exists and I don't gto any feedback from the RubyMine dev team or any other one in this forum.

0
I checked with support and they recommend source modifications to set the options at this point.  He recommended that I open a support request.  See it here:  http://youtrack.jetbrains.com/issue/RUBY-14145
0

Ever got a response from that? Have version 6 running now, still same problem.

0

I haven't heard anything on this.  I am still using Thin but changed my code so that I didn't need to pass that parameter, at least for now.

0

Please sign in to leave a comment.