Ruby class navigation stopped working. Can't run classes or specs via context menu.

In the last week or so I've suddently lost the ability to navigate to classes via Command+Click. I also can't right-click and run a spec.

The logs seem to have lots of errors (attached). I tried turning off a bunch of plugins (I recently added some for Coffee Script, Angular and Node).

I've tried:
- restart
- invaidate caches and restart
- delete project and start again from sources

I also started having trouble finding my specified SDK and gemset. I resorted to deleting the .ruby-version and .ruby-gemset from my project directory to get around this.

Dan



Attachment(s):
idea.log.zip
3 comments
Comment actions Permalink

Forgot to say.: Mac OSX Mavericks. #RM133.632, RubyMine 6.0.3

0
Comment actions Permalink

It seems code navigation works on my controllers and models, but not from within my specs.

0
Comment actions Permalink

Hi,

the problem looks very similar to http://youtrack.jetbrains.com/issue/RUBY-14835 which was fixed in our Hinoki EAP.
Could you please try it (http://confluence.jetbrains.com/display/RUBYDEV/RubyMine+EAP)

Regards, Oleg.

0

Please sign in to leave a comment.