Tab key keeps getting in my way.

More often than it's useful there's some kind of autocompletion going on when I press tab, and I cannot figure out how to disable this.

See what is happening below, when the caret is placed after :dest and tab is pressed.

# before <tab>
      :synced_folders     => {
          :src            => File.join(SRC_ROOT, 'lalala'),
          :dest
      }

# after <tab>

      :synced_folders     => {
          :src            => File.join(SRC_ROOT, 'lalala'),
          :describe  do

end
      }

No drop down list or anything is presented, it just decides that I want this completion.  Very annoying.

Any help appreciated.

1 comment
Comment actions Permalink

Those are the "Live Templates" - called "snippets" in some other editors. Open Preferences and search for Live Templates, then use the checkboxes to disable the ones you no longer wish to use.

0

Please sign in to leave a comment.