Terminal locale settings

I'm using the latest RubyMine on Mac OS X.  If I type locale in the Terminal plugin I get:

> locale
LANG=
LC_COLLATE="C"
LC_CTYPE="C"
LC_MESSAGES="C"
LC_MONETARY="C"
LC_NUMERIC="C"
LC_TIME="C"
LC_ALL=

But if I type local in the OS terminal app I get:
LANG="en_US.UTF-8"
LC_COLLATE="en_US.UTF-8"
LC_CTYPE="en_US.UTF-8"
LC_MESSAGES="en_US.UTF-8"
LC_MONETARY="en_US.UTF-8"
LC_NUMERIC="en_US.UTF-8"
LC_TIME="en_US.UTF-8"

LC_ALL=


How do I modify RubyMine so that it has the same locale settings?  The settings for Terminal in preferences are sparse.
1 comment
Comment actions Permalink

Add this line to your .bash profile

if [ -z "$LANG" ]; then export LANG="$(defaults read -g AppleLocale | sed 's/@.*$//g').UTF-8"; fi

 

0

Please sign in to leave a comment.