IntelliJ with Ruby Plugin showing valid method as invalid

Hello,

I am using the Ruby Sequel library <http://sequel.jeremyevans.net>, and one of the methods is called select <http://sequel.jeremyevans.net/rdoc/classes/Sequel/Dataset.html#method-i-select>.  However, IntelliJ is consistently telling me that the way I am using select is wront, although it is valid for the Sequel library.

Screenshot explaining what I mean can be found below.

Also, what is that wierd character I see p2=?, p3=?.  Is that for a different language?

Thanks,



Attachment(s):
invalid-select.png
4 comments
Comment actions Permalink

It looks like we think that "select" method you use is not from the library you use :(  Consider filing a bug in our tracker (http://youtrack.jetbrains.com/issues/RUBY) about it but please
provide test project to reproduce it.
As for weired symbols: it looks like some incorrectly converted UTF.  What OS and jdk are you using?  What is your locale settings?

Regards, Oleg.

0
Comment actions Permalink

Hi Oleg,

Just submitted a ticket: <http://youtrack.jetbrains.com/issue/RUBY-14868>

Regarding you other question, I am using Mac OSX 10.9, in normal US English mode.  I do not have any other locals setup.

Thansk,

-Robert

0
Comment actions Permalink

HI,

> Regarding you other question, I am using Mac OSX 10.9, in normal US English mode.  I do not have any other locals setup.

Hmm,  coul you please also file ticket about this problem so we would investigate it.  Please also add information about jdk version you use (Help|About shows all necessary information), and the way you run Idea.

Regards, Oleg.

0
Comment actions Permalink

Hi Oleg,

Just submitted it here: <http://youtrack.jetbrains.com/issue/JT-23162>

Thanks,

-Robert

0

Please sign in to leave a comment.