Oracle sequences

There are alot of sequence objects missing from DataGrip view.

Naturaly, i can see all of them on Oracle SQL Developer.

Any tips?

3 comments
Comment actions Permalink

I solved it by selecting the option "Use legacy introspector".

But what that means about the DB config?

0
Comment actions Permalink

Hello,

I see sequences in the Database tool window:

Do you see the sequences if connected using legacy introspector by the same user? Please try to un-check this option, click Forget schemas in the schema context menu and invoke Synchronize action again.

Legacy introspection option means that for retrieving information from the database DataGrip uses only jdbc driver implementation. The last versions of DataGrip have more advance introspection of Oracle types so it should work better (faster and more precise).

If problem remains, please post output of Test Connection report for Oracle data source and idea.log after invoking Synchronize action (without legacy introspector).

1
Comment actions Permalink

Just did what you said and it worked.

Thank you, Andrey.

0

Please sign in to leave a comment.