impossible to deselect 'execute in bundle context' option for test::unit

Hi,
this is probably not a bug, but I am unable to understand what is going on here. Attached screenshot shows the problem. What is this graphical test runner and is there any way to opt out of using it, so I can run tests outside of the bundle context?
The underlying problem is that we are trying to get rubymine to work with spring (rails preloader).



Attachment(s):
Screen Shot 2014-01-13 at 2.57.12 PM.png
3 comments
Comment actions Permalink

Unfortunately it is improssible now (see http://youtrack.jetbrains.com/issue/RUBY-14733)  you have to uncheck this checkbox on every run configuration instead.
Why do you need this for spring?  BTW we plan to support this in our next big release (http://youtrack.jetbrains.com/issue/RUBY-14755) and
there are some ideas on how to use spring with current RM version in the ticket.

Regards, Oleg.

0
Comment actions Permalink

Hi Oleg,
thanks for the quick reply.

I tseems we were indeed pursuing the wrong solution by trying to unclick this box.
To clarif ywhat we are trying to do, we want to get spring to run with test::unit, not rspec.

We found a kind of workaround that allows us to do that (see attached screenshot) which unfortunately makes it necessary to edit every test configuration manually to specify the spring testunit executable as a wrapper around the actual test. We dot hree steps for that:
1) make sure test script is selected
2) copy the ruby script line to runner options
3) replace the ruby script line with the full path to the spring testunit bin stub

Is there a way to make this as a global change for all tests?



Attachment(s):
Screen Shot 2014-01-14 at 2.15.52 PM.png
0
Comment actions Permalink

Unfortunately there is no such option :(

Oleg.

0

Please sign in to leave a comment.