External file changes sync may be slow: Native file watcher executable is outdated

Hi, Just tried RM 5 and got this error.

RubyMine has been upgraded properly, also:

pacman -Ql rubymine | grep fsnotifier
rubymine /opt/rubymine/bin/fsnotifier64


pacman -Ql rubymine list all files owned by the package.
22 comments
Comment actions Permalink

Hi,

What OS are you using?

Regards, Oleg.

0
Comment actions Permalink

Hi, it is:
Linux arch 3.7.6-1-ARCH #1 SMP PREEMPT Mon Feb 4 09:15:13 CET 2013 x86_64 GNU/Linux

0
Comment actions Permalink

How Rm has been installed?
As far as I know we only provide .tar.gz archieve for Linux,
so I wonder how pacman understands that /opt/rubymine/bin/fsnotifier64 is provide by this archive.
Perhaps you have used some third-party package?

Regards, Oleg.

0
Comment actions Permalink

To install something using pacman we need to build the package first, see https://wiki.archlinux.org/index.php/PKGBUILD

So nothing could be wrong here, pkgbuild extract files from the archive you provide, scan all files it contain and build a package that could be installed to the system by pacman. Pacman use information from the already installed package to remove all related files and only then install a new package version. So it is not possible also that something could be installed just over the old instalation.

I also tried to remove previous installation and ensured that /opt/rubymine directory has been removed, thus it is not possible that some files could be used from the previous installation.

Here is the PKGBUILD config file, used for my installation:
https://aur.archlinux.org/packages/ru/rubymine/PKGBUILD

Best,
Alex

0
Comment actions Permalink

Hi Alex,

I've tried RM 5.0 on my Ubuntu and everything works ok.
I'd suggest to try RM from the official .tar.gz to check if this is packager's problem or some RM problem which is specific to your system.

Regards,Oleg.

0
Comment actions Permalink

Hi, just tried and it seems to be working. Can't even imagine what could be the reason...

0
Comment actions Permalink

Not sure, it is simply create a new archive from the extracted data.

sudo rm -rf /opt/rubymine/bin
cp -r [RubyMine-5.0]/bin /opt/rubymine

And the problem has gone.

0
Comment actions Permalink

Am I right that this is pacman who is responsible for deleting old binaries?
Perhaps package description has been changed?

Oleg.

0
Comment actions Permalink

Not exactly, as I told before, I even tried to remove the previous version first and ensured that the /opt/rubymine does not exist before installing a new version.
Thus what you say is not possible.

0
Comment actions Permalink

So, it is a MAGIC ;)

0
Comment actions Permalink

Hi,
i got the same error after updating to rm 5.0.1

0
Comment actions Permalink

What OS are you using? How you have updated RM?

Regards, Oleg.

0
Comment actions Permalink

For me rhat was the PKGBUILD configuration error, missing options=('!strip'). It works great now.

strip - Strips symbols from binaries and libraries. If you frequently use a debugger on programs or libraries, it may be helpful to disable this option.

Weird that RM fails to use the binary after that.

0
Comment actions Permalink

I'm using Ubuntu 12.10. I updated rm with the update function of rm.
The error disappear after unpacking rm 5.0.1 as new installation

0
Comment actions Permalink

I also get this error using IntelliJ IDEA Ultimate (I know this is the RubyMine forum) after updating through the standard update process. When downloading a fresh .tar.gz release and extracting it and using that one the error goes away.

For reference (I don't know if this is relevant) the filesizes for the updated fsnotifier vs the fresh version (sorry I don't have the size before the update):

Filename Updated Fresh
fsnotifier 24506 bytes 22734 bytes
fsnotifier64 31987 bytes 29227 bytes


I've noticed this a number of times in the past, I can't say if it's always done this when updating vs installing a fresh version.

I'm running:
Linux version 2.6.32-279.22.1.el6.x86_64 (mockbuild@c6b10.bsys.dev.centos.org) (gcc version 4.4.6 20120305 (Red Hat 4.4.6-4) (GCC) ) #1 SMP Wed Feb 6 03:10:46 UTC 2013
CentOS release 6.3 (Final)
IntelliJ IDEA IU-128.18

0
Comment actions Permalink

It looks like a bug for me.  Has someone submitted it?

Regards, Oleg.

0
Comment actions Permalink

I can't see anything in the youtrack search, I can report it if you like?

0
Comment actions Permalink

Yes, please.  This way you will be able to track its status.

Oleg.

0
Comment actions Permalink

tl;dr; If pacman is like gentoo's portage, it strips all symbols from all binaries and that breaks pycharm.
On gentoo for example: on ebuild you must have RESTRICT="strip" directive or install pycharm with FEATURES="nostrip" emerge pycharm

0

Please sign in to leave a comment.