CoffeeScript debugger in RubyMine 6 works only when not debugging another thing (e.g. your Rails app)

This is just an FYI so people in the future can google this, and not waste a half hour like I just did.

It is probably by design, but RubyMine 6 apparently cannot debug CoffeeScript code if your Rails app (or, I presume, anything else) is running in its debugger already.

And, the symptoms might make you think the CS debugger feature just doesn't really work.

In my case, it would connect to the Chrome extension OK, open the debugger, and show all my console.log test statements... but would never stop at any debugger.

I google a bunch in vain, but finally realized oh oops, my Rails app is running in RubyMine in debugging mode. I stopped it and launched it in Run mode, then again tried to debug the CoffeeScript debug target... and it worked! Ooops.

Since googling had brought me to this forum (but to what were unrelated RubyMine CoffeeScript debugger issues), I decided to post this public service announcement.

And actually.... it would be really cool if RM could debug the Ruby on Rails server code and the CoffeeScript client code simultaneously... ;-)

RubyMine 6.0, Rails 4.0.1 with the attendant gem versions, and to get it running I followed the instructions posted at http://confluence.jetbrains.com/display/RUBYDEV/Debugging+CoffeeScript+Code precisely, and everything works now.

Please sign in to leave a comment.