Add my own rakefiles to ruby project ( non rails )

I have IntelliJ 11.1.2 with the current RubyMine Plugin ( MacOS ) and  created a ruby - project. Now i want to add a rakefile of my own and make it run by IntelliJ.

I created a simple rake test file, that runs fine when started by the shell.

Following the instructions in the help i put this file in lib/tasks (  I also tried to put it in the project root ).

But after restart the file never appears at Tools / Run rake tasks and when i click on the popup "Reload rake tasks list" I get the message:

Error: Rake action cannot be launched in current projetct context.

What am i doing wrong?

Ingo

3 comments
Comment actions Permalink

Hi,

sorry for delay (preparation of RM 4.5 beta takes too much time :()
I've created simple project with just Gemfile (it just contains rake file), added Rakefile and load it in Idea, but I was not able to reproduce the error you've got :(
Also I've an idea on why you do not see your tasks in the list: by default we do not show undocumented tasks so you should either check the "show undocumented" ckeckbox in rake tasks list popup or add documentation to your tasks (something like "desc "some description"" before the task).  After that the tasks are shown in the list.

Hope this helps.

If you still have the same error please attache a test project we could use to reproduce it (also it would be interesting to know what version of ruby do you use).

Oleg.

0
Comment actions Permalink

I'm getting the same error in the latest EAP buildof RM

extremely annoying, thank god for the terminal plugin , it works fine to rake from there

0
Comment actions Permalink

Test!!! Give me the test! ;)  As long as I can not reproduce the problem I can not fix it :(

Oleg.

0

Please sign in to leave a comment.