RubyGems not Installed for SDK Error

Hi,

I'm using rbenv to control my Ruby environment, when I select ruby from the shims directory RubyMine gives me the error 'RubyGem not installed for SDK', however I've confirmed that it is installed.

I've Googed for awhile and tried a few things, including setting the ruby.version.management.rbenv.location to my rbenv location (hoping Ruby it would be auto detected, but it wasn't, I still had to manually pick it) but nothing has helped.

Some details on my environment are below.

Any help would be greatly appreciated, I'm quite keen to give RubyMine a try.

Thanks,
-derek


➜  shims git:(master) ✗ ruby --version
ruby 1.9.3p448 (2013-06-27 revision 41675) [x86_64-darwin12.4.0]

➜  shims git:(master) ✗ gem environment
RubyGems Environment:
  - RUBYGEMS VERSION: 2.1.5
  - RUBY VERSION: 1.9.3 (2013-06-27 patchlevel 448) [x86_64-darwin12.4.0]
  - INSTALLATION DIRECTORY: /opt/boxen/rbenv/versions/1.9.3-p448/lib/ruby/gems/1.9.1
  - RUBY EXECUTABLE: /opt/boxen/rbenv/versions/1.9.3-p448/bin/ruby
  - EXECUTABLE DIRECTORY: /opt/boxen/rbenv/versions/1.9.3-p448/bin
  - SPEC CACHE DIRECTORY: /Users/sayeaud/.gem/specs
  - RUBYGEMS PLATFORMS:
    - ruby
    - x86_64-darwin-12
  - GEM PATHS:
     - /opt/boxen/rbenv/versions/1.9.3-p448/lib/ruby/gems/1.9.1
     - /Users/sayeaud/.gem/ruby/1.9.1
     - /opt/boxen/rbenv/plugins/rbenv-gem-rehash
  - GEM CONFIGURATION:
     - :update_sources => true
     - :verbose => true
     - :backtrace => false
     - :bulk_threshold => 1000
     - "gem" => "--no-ri --no-rdoc"
  - REMOTE SOURCES:
     - https://rubygems.org/
  - SHELL PATH:
     - /opt/boxen/rbenv/versions/1.9.3-p448/bin
     - /opt/boxen/rbenv/libexec
     - /opt/boxen/rbenv/plugins/ruby-build/bin
     - /opt/boxen/rbenv/shims
     - bin
     - /opt/boxen/rbenv/shims
     - /opt/boxen/rbenv/bin
     - /opt/boxen/rbenv/plugins/ruby-build/bin
     - node_modules/.bin
     - /opt/boxen/nodenv/shims
     - /opt/boxen/nodenv/bin
     - /opt/boxen/bin
     - /opt/boxen/homebrew/bin
     - /opt/boxen/homebrew/sbin
     - /usr/bin
     - /bin
     - /usr/sbin
     - /sbin
     - /usr/local/bin
     - /opt/X11/bin
     - bin
     - /opt/boxen/rbenv/shims
     - /opt/boxen/rbenv/bin
     - /opt/boxen/rbenv/plugins/ruby-build/bin
     - node_modules/.bin
     - /opt/boxen/nodenv/shims
     - /opt/boxen/nodenv/bin
     - /opt/boxen/bin
     - /opt/boxen/homebrew/bin
     - /opt/boxen/homebrew/sbin
     - /usr/bin
     - /bin
     - /usr/sbin
     - /sbin
     - /usr/local/bin
     - /opt/X11/bin

3 comments

Hi,

if you have to manually create sdk for ruby installed with rbenv then you should use one of sdk lacated under versions directory (not shims).
As for ruby.version.management.rbenv.location: what version of RubyMine are you using, the option is supported in Momiji EAP buils only (not in 5.4.X)
If you do use EAP build then please attach RM's log file (Help|Show Log in ...)

Regards, Oleg.

0

Awesomeness, that fixed the problem.

Cheers,
-derek

0

Thanks! This was the right answer. If possible, please update documentation to make this more clear :).

0

Please sign in to leave a comment.