Can't see stack frames while remote debugging

I'm working on two different machines. One is the windows7 machine with RM and the project is on a mounted network drive on the other machine, a suse linux. (not sure which version). The Rails application runs all an the linux machine. At the moment, i create an ssh connection from the windows to the linux machine.

I start the debug-server as follows:
rdebug-ide -p3401 -h host --dispatcher-port 26126 --keep-frame-binding -d  -- script/rails s -p3400

The feedback from the console:
Fast Debugger (ruby-debug-ide 0.4.18, ruby-debug-base19x 0.11) listens on host:3401

Then on my windows machine i created a Ruby remote debug with the following settings:
Remote host: host
Remote port: 3401
Remote root folder: .
Local port: 26126
Locla root folder: M\.....\....    (the local mounted project route)


I added the following lines to the Gemfile:
gem 'debugger-linecache'
gem 'ruby-debug-base19x'
gem 'ruby-debug-ide'

I did bundle install

Wenn I start the debug session in RM i get connected but I don't get any Frames and can't go forwards and backwards on the stack. It stops at the break point and see screenshot.
1.PNG

And some feedback from the linux machine:
2.PNG

I can start and stop the debugging. I can set breack points and it stops correctly, but I only get no Frames.

Has anyone a clue?

Best regards

René

11 comments

Did you resolve this problem?  I also running into same scenario.  I appreciate if you have any input on this.

-Sri

0

Hi,

have you specified remote and local folders in the remote debug configuration?

Regards, Oleg.

0

Yes, I did specify the local and remote folder correctly.  I have reproduced the problem using two different exactly same linux desktop.

0

Hi,

are you talking about remote debug or debug for remote sdk? Also it would be interesting to see output of deugger in verbose mode.


Regards, Oleg.

0

We were discussing this issue in the separate forum, http://devnet.jetbrains.com/thread/450746?tstart=0 .  It is a similar issue and I was trying to find whether this user had resolved the problem or not.

-Sri

0

Hi Sri,

yep, I've missed that your problem is the same :(
Hope the original author of the thread will also answer my questions.

Oleg.

0

Hi,

I solved the problem by set up everything on my local machine.

Before it was like this.

remote debug vs debug from remote sdk: I had RubyMine on my local machine and the SDK, Ruby runtime and the Project where on a remote Suse Linux installation in our network. The local machine has a Windows 7 os.

Best regards

René

0

Hi Rene,

> remote debug vs debug from remote sdk: I had RubyMine on my local machine and the SDK, Ruby runtime and the Project where on a remote Suse Linux installation in our network. The local machine has a Windows 7 os.

I'm not sure I've got the answer :(  Did you use RubyMine with remote sdk, or manually run ruby app on remote host and connect to it using remote debug feature?

Regards, Oleg.

0

I think I tried the second on. I startet my Ruby project on the remote machine with an enableed debug session (or something like that). And connected to that instance from my local RubyMine by setting up the remote debug port and so on.

The command on the remote machine (copied from the top post):
rdebug-ide -p3401 -h host --dispatcher-port 26126 --keep-frame-binding -d  -- script/rails s -p3400

0

For those who come across this problem in the future: I solved this issue by double-checking my local/remote folder mappings. Sure enough I had a small mistake in my mappings, one I corrected that error everything worked perfectly.

0

Heads-up - I had similar issue today and after I analyzed output provided by some of the "--keep-frame-binding -d" options, I figured out that the debugger sends frame details with the actual real path, while I entered symlink-path in remote debugger config in RubyMine. After I entered the actual real path in RubyMine - it started working like a charm. Be sure to check that! (I was using capistrano for deployment and had "current" folder as a symlink to actual release path)

1

Please sign in to leave a comment.