"Error running <test name>: Cucumber Gem isn't installed for RVM: ruby-2.0.0-p247 [global]

For some background info, I installed Cucumber by installing Calabash.  I have also cross-posted on both forums: here and here

My team was using the default version of Ruby on Mac OSX which  is 1.8.  I decided to be the team guinea pig for updating to 2.0 yesterday and ran into a blocking issue.

I did the following:
  1. Installed Homebrew: ruby -e "$(curl -fsSL https://raw.github.com/mxcl/homebrew/go)"
  2. Installed RVM: \curl -L https://get.rvm.io | bash -s stable --ruby
  3. Ran through the instructions here: http://architects.dzone.com/articles/upgrading-ruby-20-mountain
  4. Opened the RubyMine settings
    • [Settings Dialog] Changeed the Ruby SDK and Gems settings to use the new ruby version (Under Ruby SDK)
    • [Settings Dialog] Selected Update Gems
    • [Update Gems Dialog] Selected any items that need updating and then press the Update button

After that, RubyMine no longer plays nice and I get this error message: Error running Smoke Test: Cucumber Gem isn't installed for RVM: ruby-2.0.0-p247 [global] SDK

Anyone  else use this setup that might have an idea what caused the issue and  how to fix it?  I'm not very familiar or comfortable with the concept of Gems yet.  We don't have any custom gem files.  I just want to be able to use Ruby 2.0 inside RubyMine so I can update our Calabash code to use the new syntax, and because Cucumber will soon be moving away from 1.8 support.  I wasn't able to find any information on this issue within the RubyMine help docs or doing a search online.



Of course, right after I post this I figured it out and it was pretty easy to fix.  If you go into the Project Settings and go to the Ruby SDK and Gems page, you just have to select Install Gems and install Cucumber-Calabash.


@Teresa I am facing same issue, I tried the steps you mentioned but couldn't find the the Gem "Cucumber-Calabash"



do you have this gem installed in your project SDK?


@pajain are you using Calabash or just Cucumber?


@olga Yes it is installed, @Teresa I am using just Cucumber


Since you're not using Calabash, don't use my exact solution :). Try uninstalling Cucumber, then reinstalling it. You may have to install it directly in Rubymine. Basically follow my solution but install Cucumber instead of Cucumber-Calabash.



I am facing similar kind of issue while running feature file. Error says: Cucumber Gem isn't installed for ruby-2.0.0-p648 SDK

I have tried couple of different ways which were mentioned in previous comments. I am able to run files from my command prompt in my MAC OS (Version 10.12.6) , but I would like to run and debug files through Ruby Mine.  I have attached screenshot of my project settings screen below. Any feedback is welcome. Thanks!





according to your screenshot 'cucumber' gem isn't installed. Could you please check its presence in `gem list` output (please make sure you're using the same Ruby SDK as the one set in RubyMine's Preferences)


I am facing the same issue with Cucumber


Installing latest version of IDEA solved my issue...  I Was in Version 15, upgrading to 17 resolved it.


Please sign in to leave a comment.