Rubymine fonts not behaving after Wine install

I've been a very happy Rubymine user for a couple years and suddenly notice two weeks ago that the fonts rendering became suddenly blockier (see attached screenshot).  Especially the navigation tree seems to be bold text, though the code editor also seems less readable for certain highlights.  The only thing I could think of that I had done prior was installing Wine, but I'm not sure how that could have impacted Rubymine.  I was hoping whatever had happened would reset itself with the 4.5 release, but no such luck, so it seems like a system issue (though Rubymine seems to be the only app affected).  Changing the look and feel settings and overriding fonts only seems to impact menus and a few buttons, with no impact on the nav tree or the editor.

Please let me know if there's something I can do to try and diagnose the issue as I've run out of ideas.  I uninstalled Wine with no effect on Rubymine so that may have been a red herring.

Thanks,
Louis

edit:

Looks like it may be a Java thing.  Had no luck searching prior, but as soon as I posted the related posts showed up.  I tried http://devnet.jetbrains.net/message/5250888#5250888 which didn't seem to help anything.



Attachment(s):
Screenshot from 2012-07-20 18:24:54.png
8 comments
Comment actions Permalink

Hello Louis,

this may be caused by msttcorefonts package (or some package with the similar name) that gets installed as a Wine dependency. You can uninstall it and fonts would be back to normal, Wine should work ok without this package.

0
Comment actions Permalink

Hi Dennis,

The closest package I could find was ttf-msscorefonts-installer, so I completely removed it.  Based on this post (http://askubuntu.com/questions/86335/installing-other-fonts-on-wine) I checked the following folders for things that looked like microsoft fonts:

/usr/share/fonts
/usr/share/wine/fonts (has some *.fon files with names that seem suspicious like "courier.fon" but nothing saying microsoft)
~/.fonts (folder didn't exist)

Nothing jumped out at me. Is there a way to identify which font Rubymine is loading?

Thanks,
Louis

/usr/share/fonts
/usr/share/fonts/usr/share/fonts
/usr/share/wine/font

0
Comment actions Permalink

You can try overriding font used in non-editor components in Settings | Appearance as a workaround.

0
Comment actions Permalink

I tried that and it only seems to affect the text on the left-most tabs pane (not sure what the proper name is). Effect set to extreme for clarity in the attached.  I've tried changing the look and feel with similar effects.  The look and feel changes but the stubborn text stays bold.



Attachment(s):
Screenshot from 2012-07-27 17:31:29.png
0
Comment actions Permalink

I managed to solve this problem removing following folder:
/usr/share/fonts/truetype/unfonts-core

0
Comment actions Permalink

removing /usr/share/fonts/truetype/unfonts-core worked for me to get rid of the bold menues and sidebar contents. but afterward inside the editor the monospaced font seems to have brittle edges(broken?).

0
Comment actions Permalink

Hi Georg.  Can you attach a screenshot in case somebody comes along trying to see if they're issue is the same?  I've since reinstalled my OS and reinstalled Rubymine and haven't had any problems.

Thanks,
Louis

0
Comment actions Permalink

Thanks, removing fonts-unfonts-core package (which owns /usr/share/fonts/truetype/unfonts-core) solved the problem.

0

Please sign in to leave a comment.