"Cannot find declaration to go to" RM4.5 Linux

Hello,

I'm running RM4.5 on Ubuntu 13.04
When I try to use CTRL-B to jump to a method of one of the gems I am using, I get the error:
"Cannot find declaration to go to"

However, I can run the code, so it does find it at runtime (I run the code from RM).

Any ideas what I am missing? Is my GEM setup incorrect?

I tried searching this forum, but could not find anything related.

Thanks,
Rob.

3 comments

Hi Rob,

it looks like a bug for me, could you please try the latest RM (better the latest EAP) and see if the problem is still reproducible.
And if it is feel free to file a bug in our tracker http://youtrack.jetbrains.com/issues/RUBY

Regards, Oleg.

0

Hi Oleg,

thanks for your reply.
The problem with upgrading is that I don't have a license for the latest version. I bought a license when I started using RM, but
I have not renewed it, so I can't upgrade.

Are you saying that I should renew the license and then upgrade to the latest RM?
Is the version I am on no longer supported at this point?

Thanks again,

Rob.

0

Hi Rob,

you are allowed to try any version of RM for 30 days so you do not have to upgrade your license.
Also the license is not a license for particular version but licence to update RM during one year
(and after the year you are allowed to use the version you've got as long as you want)
so if you've bought it less than year ago you still allowed to update RM.
And yes RM 4.5 is not supported anymore :(  The latest version is 5.4.3.

As for EAP: it is possible to use it w/o any license (while we have EAP opened).

Hope I have answered your questions about license if not feel free to ask more.

Oleg.

0

Please sign in to leave a comment.