Debugger broke, missing gems?

I started playing with gemsets and weird things have started to happen. RubyMine version is 4.0.3, Build # RM-117.320, Built on April 18 2012.

I have created an app called loco from command line. I have also created a gemset called loco for the app.
In Rubymine the project is set to use Ruby 1.9.3  and the loco gemset.

Screen Shot 2012-07-25 at 5.31.02 PM.png
I modified the gem file to add some gems. From comamnd line did bundle install. Gemfile and gemlock files are attached.

From RubyMine if I run the debug, I get this:
Screen Shot 2012-07-25 at 5.05.58 PM.png

Saying Yes ultimately results in:
Screen Shot 2012-07-25 at 5.05.46 PM.png
Following instructions here: http://devnet.jetbrains.net/thread/434612 I tried to install the ruby-debug-base19x, linecache etc from command line. I encountered other problems like:

gem install linecache
Fetching: rbx-require-relative-0.0.9.gem (100%)
Fetching: linecache-0.46.gem (100%)
Building native extensions.  This could take a while...
ERROR:  Error installing linecache:
     ERROR: Failed to build gem native extension.

        /Users/sony/.rvm/rubies/ruby-1.9.3-p194/bin/ruby extconf.rb
Can't handle 1.9.x yet
*** extconf.rb failed ***
Could not create Makefile due to some reason, probably lack of
necessary libraries and/or headers.  Check the mkmf.log file for more
details.  You may need configuration options.

Provided configuration options:
     --with-opt-dir
     --with-opt-include
     --without-opt-include=${opt-dir}/include
     --with-opt-lib
     --without-opt-lib=${opt-dir}/lib
     --with-make-prog
     --without-make-prog
     --srcdir=.
     --curdir
     --ruby=/Users/sony/.rvm/rubies/ruby-1.9.3-p194/bin/ruby


Gem files will remain installed in /Users/sony/.rvm/gems/ruby-1.9.3-p194/gems/linecache-0.46 for inspection.
Results logged to /Users/sony/.rvm/gems/ruby-1.9.3-p194/gems/linecache-0.46/ext/gem_make.out


Tried installing specific version, 0.43, still did not work. I ended up uninstalling the ruby-debug gems and installing again a couple times.

At present if I do gem list, I see
linecache19 (0.5.13)

ruby-debug-base19x (0.11.30.pre10)
ruby-debug-ide (0.4.17.beta9)



These gems are in the loco gemset.

What do I need to do to fix the setup so that the debugger works?

Attachment(s):
Gemfile.lock.zip
Gemfile.zip
3 comments
Comment actions Permalink

Hello,

this was a problem on RubyForge site, it was discussed in the RUBY-11768.
Looks like it's fixed on their side now.

0
Comment actions Permalink

Thanks! It is fixed. RubyMine was able to install the gems and debugger worked.

0
Comment actions Permalink

This issue seems to have reappeared.
Screen Shot 2013-06-29 at 10.41.55 PM.png

0

Please sign in to leave a comment.