Automatic carriage-return for git commit comments

Hi,

This is a minor - but annoying - thing that has popped up in version 5.4...

When I fire up the Git > Commit-Changes dialog box it has a "Comment" textarea at the bottom of the box. As far back as I can remember this textarea atuomatically scrolled to the next line when typing in the comment - which was really nice.

I use RM at home and at work.Starting with version 5.4 my home version has stopped inserting the atuomatic newline; instead a horizontal scrollbar appears at the bottom of the textarea. What is weird is that this does not happen with the version I use at work.

Commit comments are oftentimes long and I'm usually not looking at the textarea while I am typing. When I do look up I see that instead of a nice paragraph I can proofread, I have one loooong line that scrolls off to the right, which means I have to manually insert carriage-returns to break that line up.

I have looked all over for a setting to control this but cannot find it. Can someone tell me how I can get the old behavior of automatically inserting carriage-returns while typing Git commit comments?

As always, thanks for the GREAT IDE!

-- Larry

2 comments

HI Larry,

Please try enabling/disabling Settings | Version Control | Set right margin in the commit dialog and see if that helps.

0

Hi Kirill,

Thanks for the quick reply... and your instructions worked like a charm! (In retrospect it seems like I should have been able to see/find that. But I guess that's how it always appears once you know where something is.)

Thanks again,
Larry

0

Please sign in to leave a comment.