SDK not recogised after upgrade from Rubymine 4.0 to 5.4

I recently upgraded from 4.0 and 5.4 and I am unable to run tests from within my IDE (I've tried both RSpec and Cucumber tests thus far).

I can confirm that Rubymine successfully detects my RVM SDK's, and I have configured the correct SDK in the 'Ruby DSK and Gems' project settings.
My tests are configured to 'Use project SDK', and the SDK is shown correctly on the 'Run/Debug Configurations' pop-up defaults.

The only feedback I am receiving when attempting to run a test is: 'Error running <test name>: No SDK specified.

I have attempted to:
* Remove all the SDK's, restart Rubymine, quadruple check the configuration and run tests again
* Install and Upgrade Gem's in my selected SDK (in the hope that Rubymine would better 'recognise' the SDK) without success
* Explicitly specify an SDK in the tests 'Run/Debug Configurations' pop-up

Interestingly, when I:
1. Clean all the test 'Run/Debug Configurations' (and just leave the defaults)
2. Run a test, and thus create a 'Run/Debug Configurations' entry for it

The created entry is configured to 'Use project SDK' however the Project SDK shown is blank.
When I change the Configuration of the test to 'Use other SDK...' and re-run the test, it continues to fail and the 'Run/Debug Configurations' pop-up reverts to 'Use project SDK' with a blank SDK.

I'm an experienced IntelliJ and RubyMine user and this one is a mystery...please help!

1 comment

For those who experience this problem in future, I managed to solve this by removing the projects .idea folder and re-opening the project directory (aka create a new RubyMine project).

Not sure if a re-index may have also solved the issue...

0

Please sign in to leave a comment.