How can I banish the Gem Manager warning?

I'm using RubyMine 4.0.3, build # RM-117.230.

On Mac OS 10.7.3.

I'm using RVM to manage my gems, so have not used the RubyMine Gem Manager.

This yellow dialog keeps appearing in the upper left corner. It pops up when I launch RubyMine and at other times too. Maybe every time I open a new project. I haven't figured out the pattern yet.

gem_manager_warning.jpg
I tried to disable that inspection, as shown below, but this had no effect. The warning keeps popping up throughout the day.

I am actually not missing any gems because again I am using RVM and not using RubyMine to manage my gems.
gem_inspection.jpg
How can I completely remove that missing gems warning permanently?

Thanks.

6 comments
Comment actions Permalink

I believe it is in Settings | Notifications

0
Comment actions Permalink

Thanks.

I went into Settings > Notifications.

I unchecked "display balloon notifications" and also "gem manager" and "gems".

notifications.jpg

I clicked "apply" and then "OK".

Restarted RubyMine.

The gem notification is still appearing.

I reopened Settings > Notifications and found that the "display notifications" checkbox was unchecked, so the notifications setting did not have any effect and it did not persist.

0
Comment actions Permalink

Well, I'm not an expert on this (never used it myself) .. but instead of turning it off completely (in case this option is broken) try disabling individual popups: the value in "Popup" column -- set it to "No popup".

BTW -- unchecking in "Log" column does not stop popup from appearing -- it only affects logging it in Event Log tool window

0
Comment actions Permalink

I'm still getting this, despite doing what should obviously remove the balloon warning in the settings, as you've shown.
I gather this is a bug, almost a year old now, that no one is interested in fixing?
I'm on RubyMine 5.0.2 - and I get this balloon warning every few minutes - even after going into notification settings and unchecking the Nofitification options for "Gem Manager" or selecting "no popup".
Disabling all balloon notifications seems to work, but that should hardly be necessary, should it?

0
Comment actions Permalink

Hi,

I think the problem has not been fixed because nobody filed a ticket about it in our tracker (http://youtrack.jetbrains.com/issues/RUBY) :(
Please file one to help us ;)

Regards, Oleg.

0

Please sign in to leave a comment.