Bundle update hangs indefinitely when building from a git repository

I have my Gemfile configured as below:



source :rubygems

gem 'gem1', :git => 'git://github.com/user/gem1.git'

gem 'gem2', :git => 'git://github.com/user/gem2.git'

gem 'gem3', :git => 'git://github.com/user/gem3.git'

gem 'gem4', :git => 'git@git.ourlocalgit.com:gem4.git'

....



Whenever I do a "bundle update", I see Rubymine updating gem1 - 3, but hanging forever on gem4.  I don't have any problems running "bundle update" from the command line for this repo/project, but it does ask me for my ssh password.  I suspect that my password is needed, but Rubymine doesn't prompt me for a password.

I have tried several things to get this to work, resetting caches, restarting Rubymine, looking in the logs, running with a native executable instead of the built in one - all with the same result.  Am I doing something wrong?

I am currently running the Rubymine 5 beta (Enoki RM-125.9).

3 comments

Tried several other things:

1) update to latest Rubymine (125.39) - Rubymine still hangs
2) regenerated all of my .ssh keys - Rubymine still hangs
3) ran ssh-agent and added my key to it, then verified that a bundle update DOES NOT ask for my password, changed Rubymine to use native ssh - Rubymine still hangs

:(

0

This is happening on Windows with Git 1.8.x installed
Rubymine has path to installed Program Files\git\bin\git.exe
ssh: native or builtin (I tried on both).
With passwordless ssh key it works.
For ssh keys that require passwords it hangs even if my key is in ssh-agent

0

It looks like a bug for me.  Please file it in our tracker against git module (http://youtrack.jetbrains.com/issues?q=%23IDEA+%23%7BVersion+Control.+Git%7D+)

Regards, Oleg.

0

Please sign in to leave a comment.