rubymine doesnt find JDK

i've installed jdk 1.6 and sets the JDK_HOME to /usr/java/jdk1.6.0_41
then i tried to run rubymine.sh and got an error
     ERROR: cannot start RubyMine.
     No JDK found. Please validate either RUBYMINE_JDK, JDK_HOME or JAVA_HOME environment variable points to valid JDK installation.
what am i missing?

2 comments

It is hard to say what could be wrong, but I'd suggest to double-check if /usr/java/jdk1.6.0_41 contains jdk not jre (for example jre doesn't have javac).
Second, check that neither RUBYMINE_JDK nor JAVA_HOME are set.
If both checks won't help then I'd suggest just walk through rubymine.sh to see why it thinks that this is not a jdk (I can do this for you but remote debug through forum will be too slow ;))

Hope this helps, Oleg.

0

i just found what it is. i needed to put export JDK_HOME.

i put in the .bashrc just
JDK_HOME=/usr/java/jdk1.6.0_41

when i test it with echo it worked, some how i though to add export to it and it did the trick.

thanks anyway

0

Please sign in to leave a comment.