Evaluate expression times out at 10 seconds: how increase it?

Am using Rubymine for building and debugging automated testing scripts (using Watir and Watir-webdriver) against browsers.   When the browser takes a while to respond I can easily run over the 10 second timeout in evaluate expression.   How can I increase this timeout interval?  Am using 4.5.2 under Windows XP.

8 comments
Comment actions Permalink

You can do it in File | Settings | Debugger | Ruby

0
Comment actions Permalink

There is no Ruby option under File -> Settings -> Debugger.   Are you referring to the Debug connection timeout value?

0
Comment actions Permalink

Changing the Debug connection timeout doesn't do the trick.   
The evaluation times out after 10 seconds and throws a timeout exception.   Even if I rescue that exception attempting to execute the next line in the script causes the run to terminate ("Thread killed").

0
Comment actions Permalink

Any other suggestions?  Ruby option under File -> Settings -> Debugger does not exist.

0
Comment actions Permalink

In 4.5.4 File | Settings | Debugger | Ruby does not exist.   Please respond.

0
Comment actions Permalink

In 4.5.4 File | Settings | Debugger | Ruby does not exist.   Please respond.

Are you sure about it?

RubyMine v4.5.4

screen01.png

0
Comment actions Permalink

Yes, although it may be because I disabled the javascript debugger as am not using it and having performance issues with 4.5.x

10-26-2012 12-41-50 PM.png

Setting for debug connection timeout does not seem to affect the Evaluate Expression timeout:

'Timeout: evaluation took longer than 10 seconds.'

pat

0
Comment actions Permalink

Setting for debug connection timeout does not seem to affect the Evaluate Expression timeout:

'Timeout: evaluation took longer than 10 seconds.'

I do not know then.

I may only suggest submitting a ticket to the Issue Tracker (if it is not a bug then maybe it will be treated as Feature Request).

0

Please sign in to leave a comment.