[solved] Can't push to GitHub under Windows

Hi!

I've set up Git on Windows 7, as explained by help.github.com.

I can push to GitHub via TortoiseGit fine.

But when i try doing that via RubyMine, it fails.

Here's what i do:
1) Create a new project, fill in the README.
2) VCS → Import into Version Control → Share project on GitHub.

RubyMine asks for GitHub login/password and succesfully creates a new empty project on GitHub. But then it fails.

On my current PC, it freezes like this:
http://img21.imageshack.us/img21/4405/rubyminegithubstuck.png
On my work PC, it produces an error message like the one in this thread:
http://devnet.jetbrains.net/message/5308095#5308095
But unlike the problem in that thread, i don't have SSH key issues (Git and TortoiseGit work fine with GitHub).

I've set up Putty Agent, but it won't help.

I've tried switching RubyMine to native SSH mode, but then it would do nothing (heil Windows!).

I'm currently using a workaround: commiting with RubyMine and pushing with TortoiseGit, but this is no good.

Please help me resolve the issue.

PS I've noticed that if i kill the Java process that RubyMine starts (might be the RubyMine SSH agent), then two things happen:
1) RubyMine complains that the connection had been hung unexpectedly;
2) RubyMine asks for an SSH key passprhase! Yay!
Unfortunately, i couldn't test it further because all RubyMine does while trying to push changes to GitHub is complaining "Nothing to push". :(

UPD Oleg Sukhodolsky has pointed me below to a solution by Noah Zucker. It worked like a charm!

Message was edited by: Andrey Mikhaylov (link to a solution added).

0
6 comments

Hello Andrey,

1. Is "push" the only remote operation that fails for you in RubyMine? I.e. does Update Project, Pull, Fetch succeed?

2. Please check your .git/config and check the type of the remote url: is it http or ssh?

3. Please attach the log file.

0

I'm getting this issue also. It creates the project on GitHub and then fails.

Here's the url in the config:
url = git@github.com:ellisgl/x1022_pdo.git

Here's the logs from the VCS section:

19:21:44.985: cd C:\Users\geeklab3\Dropbox\x1022_pdo
19:21:44.986: git init
19:21:45.658: cd C:\Users\geeklab3\Dropbox\x1022_pdo
19:21:45.658: git add --ignore-errors -- README
19:21:45.745: cd C:\Users\geeklab3\Dropbox\x1022_pdo
19:21:45.745: git commit -m "First commit" --
19:21:45.924: cd C:\Users\geeklab3\Dropbox\x1022_pdo
19:21:45.924: git push -u origin master
Initialized empty Git repository in /cygdrive/c/Users/geeklab3/Dropbox/x1022_pdo/.git/
[master (root-commit) 55fabd7] First commit
1 files changed, 2 insertions(+), 0 deletions(-)
create mode 100755 README

SSH: authentication methods: [publickey, keyboard-interactive, password] last successful method:
java.io.IOException: Authentication failed:
 at org.jetbrains.git4idea.ssh.SSHMain.authenticate(SSHMain.java:281)
 at org.jetbrains.git4idea.ssh.SSHMain.start(SSHMain.java:156)
 at org.jetbrains.git4idea.ssh.SSHMain.main(SSHMain.java:136)
fatal: The remote end hung up unexpectedly

0

For me this work:
Make sure that the in File->Settings->Version Controller->Git that the path to the Git executable is correct and not C:\Cygwin the one.

I also removed the passphrase from my RSA key.

0

Hey Kirill,

sorry for not replying. I haven't been using RubyMine for a while.

1) Nope, everything fails other than creating a new repo (which is a GitHub.com API feature, not a Git feature).
2) It's "git@github.com:lolmaus/dir_size_renamer.git".
3) Kenneth McCall has posted one here. Mine is identical.

Also, as Kenneth McCall noted, removing the passphrase is the only option for Git integration to work. But it is a hardly acceptable solution!



Attachment(s):
futurama_fixit-555[1].gif
0

I believe the problem is the same as http://youtrack.jetbrains.com/issue/IDEA-54554
BTW last comment in the ticket provides some woraround.

Hope this helps, Oleg.

0

Thank you Oleg, it worked out flawlessly.

0

Please sign in to leave a comment.