Unregistered Git root detected The directory /X/git is under Git, but is not registered in the Settings.

Hi,

I keep getting this error message and want to know what the problem is.

I am on the master branch, the project is fine, the remote store is Bitbucket and that is all setup and works. I can push and pull. The root directory of this rails project *is* in the settings, but I keep getting this.

Does anyone know why this keeps appearing please? I have the option to ignore, but I have already had one git disaster this week and don't want another, so I am nervous about it.

Thanks,

Kevin

7 comments
Comment actions Permalink

Hi Kevin,

most likely you have one more git repository inside your project (X/git). RM detects it and suggests to add it to list of git roots.
After the new root added RM will be able to update/commit/show changes in both repos. If you do not need this functionality feel free
to agnore this message.
If you do not have second repo then it looks like a bug for me and I'd suggest to file it in our tracker (http://youtrack.jetbrains.com/issue/RUBY)

Regards, Oleg.

0
Comment actions Permalink

No there is only one project.

Before I file a bug report and waste anyones time, I am wondering if all these git issues I am having are due to the way this project was setup? I am doing Michael Hardl's Ruby on Rails Tutorial (Railstutorial.org). Initially I did not use Rubymine to start this project. I started it using the command line and around chapter 5 I decided to change over and use rubymine. I already had a .gitignore file and everything was ok, but I got sick of Redcar crashing and decided to try Rubymine.

Ever since taking over the existing project I have had quite a few strange errors, especially with git, and I suspect that if I start a project fresh I will not have the same problems. Messy :)

If you think that this may be the reason then I won't file the bug but will wait to see if it recreates the next new project I actually create.

0
Comment actions Permalink

I'd suggest to try to reproduce the problem with different project first, since any bug needs "steps to reproduce" otherwise it is not very useful :(

Regards, Oleg.

0
Comment actions Permalink

The other thing that is happening is I now have .gitkeep files in every directory?? This is really weird. I am running 4.5.3 in a Ubuntu VM and it was doing fine up until a couple of days ago when I had that huge git mess up and lost work.

This is very confusing :) What on earth is a .gitkeep file suddenly showing for and what is it?

0
Comment actions Permalink

I think I have solved this mystery, in one sense. On examination there was a directory "git" in my project that was never there before, is not on remote master or any branches. Removing this directory that appeared from nowhere has fixed the problem.

I am starting to think I am in the Bermuda Triangle or something. I don't know what the hell is going on here :) Every time I get my concentration back and continue with the tutorial something else ridiculous from "Tales of The Supernatural" jumps in and stops me programming!

EDIT: Though I still have the gitkeep files that also mysteriously appeared out of nowhere and are now in every directory.

0
Comment actions Permalink

Thanks Oleg. I am looking forward to starting my own project from scratch, I think that will work a lot better :)

0

Please sign in to leave a comment.