html tag completion behavior

I tried this in PHPStorm and the behavior is different.  I'm not sure if this is a setting I need to change, or, this is an anoying ?:| behavior when entering html tags in RubyMine.

Steps:

Start to enter a tag with a "<"

List comes up and I choose one, say "div" and hit the spaebar

The IDE editor yields a <div ="" with the cursor at the position before the "=" symbol.
I type "I" and code hinting comes up, suspecting I want "id".  I hit the spacebar to insert it
The cursor just sits there after the "d" and so I move it to the point between the quotes.
I enter my id selector name and imeaditely I get <div id>

Now I do notice that one of the setting is effecting this behavior, not exactly as in PHPStorm, but it makes sort of an improvement:

html editor-1.png

If I turn this setting: Automatically start attribute off, then the behavior is like this:

Start with the "<", then div autocomplete comes up, select div and use the spacebar to do so
Start with "I" and autocomplete comes up, I select and spacebar for "id"
I get <div id="" and the cursor is after the second quote plus a space

Not exactly the best either as wouldn't I want the cursor between the quotes so I could enter a selector name?

Do I need to be coding my own behaviors?

I may be totally off here and missing something.  I hope so.

Assistance is much appreciated!

Thanks,

-John

1 comment
Comment actions Permalink

Ohhhhhhh!  :8}

Using the enter key instead of the spacebar is the ticket with the setting on!

Face palm! :O

Sorry.

But maybe my missunderstanding will become someone else's understanding.

Thanks,

-John

0

Please sign in to leave a comment.