RubyMine starts (shows flash page), then vanishes!

So I figured this out after about an hour. Thought I'd save someone else feeling equally stupid in the future...

I'm migrating to a new laptop, using Ubuntu.  After getting all the underpinnings set up (real Oracle Java, etc), I started RubyMine. It showed the flash page, accepted my license info, and then -- disappeared!

I saw nothing wrong in the RubyMine log, and removing the cache files and restarting didn't help. This time, it just showed the flash page, then disappeared immediately.

The problem was that it was opening the RubyMine window off of my screen!  I have a larger external monitor, but the window wasn't either on the laptop's built-in monitor, nor on the external monitor.  To all appearances, RubyMine was running -- it was in the toolbar, and showed when I used  "ps aux" from the command line.

Unfortunately, Ubuntu doesn't give any way to 'move' a window except with the mouse -- which doesn't help if it isn't visible.

So, I fixed this by disabling my external monitor from Ubuntu's display control panel. RubyMine then popped into existance on the laptop's builtin monitor. After that, I could re-enable the external monitor and use RubyMine...

(Is there an emoticon for banging my head on a wall?)  Guess I'll go with :^O ...


Mark, could you please post an output of xrandr command (while dual-headed)?


Hi Roman,

I see that happening occasionally too, so I thought it might be useful for you if I provide my xrandr output also.

Screen 0: minimum 2880 x 1200, current 2880 x 1200, maximum 2880 x 1200
default connected 2880x1200+0+0 0mm x 0mm
   2880x1200      50.0*

Sometimes restarting RubyMine (after killing the task) is enough to get the window back, other times I need to reboot - I've never tried disconecting one of the monitors.

Display hardware configuration:
     NVIDIA GeForce GTS 450

     Idek Iihama PLE511 1600x1200     (DFP-1)
     DELL E177FP 1280x1024            (CRT-0)

Hope those details are of some assistance.

Kind regards,


Hi Roman,

This is what I see from xrandr:

Screen 0: minimum 320 x 200, current 3648 x 1280, maximum 8192 x 8192
LVDS1 connected 1600x900+2048+380 (normal left inverted right x axis y axis) 382mm x 214mm
   1600x900       60.1*+
   1440x900       59.9  
   1360x768       59.8     60.0  
   1152x864       60.0  
   1024x768       60.0  
   800x600        60.3     56.2  
   640x480        59.9  
VGA1 connected 2048x1280+0+0 (normal left inverted right x axis y axis) 641mm x 401mm
   2048x1280      59.9*+
   2048x1152      60.0  
   1920x1200      59.9  
   1600x1200      60.0  
   1280x1024      75.0     60.0  
   1280x800       59.8  
   1152x864       75.0  
   1024x768       75.1     60.0  
   800x600        75.0     60.3  
   640x480        75.0     60.0  
   720x400        70.1  
HDMI1 disconnected (normal left inverted right x axis y axis)
DP1 disconnected (normal left inverted right x axis y axis)


Thank you.
Just to make sure, could you guys please download attached Java class and run it (with "java DisplayConfig" from download location) and post its output?


Hi Roman,

I've attempted to execute the file that you attached, but no matter what I try I always get an error message along the lines of:

Exception in thread "main" java.lang.NoClassDefFoundError: DisplayConfig
Caused by: java.lang.ClassNotFoundException: DisplayConfig
    at Method)
    at java.lang.ClassLoader.loadClass(
    at sun.misc.Launcher$AppClassLoader.loadClass(
    at java.lang.ClassLoader.loadClass(
Could not find the main class: DisplayConfig. Program will exit.

I tried with the file left in the zip and with the file extracted from the zip... all to no avail.

Any suggestions?

Kind regards.
Typical... I just posted that and had an idea of setting the classpath... that worked, so here are the results:

geoffr@geoff-ubuntu:~/Downloads/RubyMine$ java -cp . DisplayConfig
:0.0: java.awt.Rectangle[x=1600,y=0,width=1280,height=1024]
:0.1: java.awt.Rectangle[x=0,y=0,width=1600,height=1200]

Kind regards,


Thank you.
But that's pretty strange - Java should be able to pick a class from a current directory. Which Java version do you use?


Hi Roman, Here's output:

$ java DisplayConfig
:0.0: java.awt.Rectangle[x=2048,y=380,width=1600,height=900]
:0.1: java.awt.Rectangle[x=0,y=0,width=2048,height=1280]


Please sign in to leave a comment.