No Rails found in SDK

RubyMine-98.47

$ rvm info
rvm:
  version: 1.0.13
ruby:
    interpreter:  "ruby"
    version:      "1.9.2p0"
    date:         "2010-08-18"
    platform:     "x86_64-darwin10.4.0"
    patchlevel:   "2010-08-18 revision 29036"
    full_version: "ruby 1.9.2p0 (2010-08-18 revision 29036) [x86_64-darwin10.4.0]"
homes:
    gem:          "/Users/payne/.rvm/gems/ruby-1.9.2-p0@project"
    ruby:         "/Users/payne/.rvm/rubies/ruby-1.9.2-p0"


In Ruby SDK and Gems:
Ruby Interpreter: Ruby SDK 1.9.2-p0 [project] (~/.rvm/rubies/ruby-1.9.2-p0/bin/ruby)
Language level: version 1.9
RVM Gemset: project

There are no missing or unattached gems listed.

Run/Debug configuration:
Server: default
Port: 3000
IP Adress: 0.0.0.0
Ruby arguments: -e STDOUT.sync=true;STDERR.sync=true;load($0=ARGV.shift)
Ruby SDK: User project SDK: Ruby SDK 1.9.2-p0 [project] [1.9]
An error alert is visible at the bottom of this panel: Run Configuration Error: [No Rails found in SDK]

If I attempt to run this configuration, I get a red alert notification that reads: "Error running Development: project: [No Rails found in SDK]"

However:
$ bundle show rails
/Users/payne/.rvm/gems/ruby-1.9.2-p0@projects/gems/rails-3.0.0

also:
$ rails server
works.

I just can't get the server to start in RubyMine. It was working previously, but quit (perhaps after doing a "bundle update"?). Anyone know how I can get this working in RubyMine? I've already tried unattaching and re-attaching the rails gem and re-launching RubyMine.

P.

28 comments

Paul,
'
Please attach diagnostic info from RubyMine | Tools | Show Gem Environment dialog.

0

I rebooted my machine and the problem did not reoccur.

0

Ok, please let me know if you will face again with the issue.

0

Hi,

I have the same problem, but reopening rubymine didn't help me... It still says Error running Development No Rails found in SDK but rails 3.0.3 seems to be installed correctly!

Thanks for help!
Markus

PS: I am able to start the server from the terminal but not form inside rubymine... I even tried to restart the computer but this didn't help neighter.

0

I am having a similar problem when trying to use the Ruby plugin for IDEA running on Ubuntu 10.04.
Fair Warning: I am completely new to IDEA, so this may well be a noob error.

Ruby (1.9.1), gem (1.3.5) and rails (2.3.10) are installed and work from the command line.
Gems are installed under /home/peter/.gem
Following the process:
    New Project -> Create project from scratch -> select Ruby Module
    -> select Ruby SDK -> select Ruby on Rails
I get a warning message "Your SDK doesn't contain Rails Framework".

Going back a screen and configuring the Ruby SDK, I manually change
'Gems bin directory' to /home/peter/.gem/ruby/1.9.1/bin
This removes the warning, and it is possible to finish setting up the new project.
However, despite successfully creating and populating the rails directory structure,
the editor window now has the warning "Some of the required gems are not attached: rails,..."

What configuration setting have I missed?  Or what further information would you like?

Thanks for your help.

0

Please open "RubyMine | File | Settings | Ruby SDK and Gems" dialog.
1. Check that correct interpreter is chosen in combobox
2. Do you see rails gems among attached gems? Are versions marked as "red"?

Also please attach diagnostic info from RubyMine | Tools | Show Gem Environment dialog

0

Please open File | Project Structure | Modules | [your module]. Do see Gem Manager tab? Check that sdk is 1.9.1 and try to press "Attach Gems..." button and select rails gem.
Which IDEA and Ruby plugin do you use? See Help | About and Help | About Ruby plugin... actions

0

Thanks for the response.

Yes I see the 'Gems' tab.  The correct (1.9.1) Ruby SDK is selected.

Unfortunately, the 'Attach Gems...' button is greyed out and unpressable.
(Also the warning message
    "Rubygems not installed for SDK: Ruby SDK 3rd.
     Please download and install rubygems"
is displayed at the bottom of the 'Project Structure' page.
'Ruby SDK 3rd' is my name for the 'Module SDK'.)

IDEA version is 10.0 Build #IU-99.18
Ruby plugin is build 3.0.17091

Hope this helps!

0

Please paste here diagnostic info from Tools | Show Gem Environment. Seems ruby plugin doesn't recognized your rubygems installation and thus nothing works.

0

The 'Show Gem Environment' is greyed out.

So yes, I think you are correct that the plugin doesn't recognize my rubygems.
How do I make it do so?  What is it looking for?

Thanks!

0

Your rubygems version is out of date, please update it. You need to launch in console

gem update --system

I'm not sure, but may be it will help. Also please restart RubyMine after rubygems has been updated

0

gem update --system is disabled on Debian, which Ubuntu is built on.

I'm really not keen to start going down the 'building things from source' route
on this machine.

Does the Ruby plugin really require a version of gems later than 1.3.5?

0

>gem update --system is disabled on Debian, which Ubuntu is built on.

"gem update --system" is NOT disabled in Debian or Ubuntu

0

Thanks for the post, Nazar.  It would possibly be more helpful
if you told me on what basis you make your assertion.

I made my statement based on the response to typing
    gem update --system
on my system, which was
    ERROR:  While executing gem ... (RuntimeError)
    gem update --system is disabled on Debian. RubyGems can be updated using the official Debian repositories by aptitude or apt-get.

Googling for "gem update system ubuntu" gives several pages
(including one from stackoverflow) that support the view that
this is indeed the case.

0

IFFIITFM !  (I Finally Found It In The Flaming Manual)

The hint is in www.jetbrains.com/ruby/webhelp/ruby-sdk-and-gems.html

The key sentence is "RubyMine looks for the scripting gem (gem, or, in case of Ruby 1.9, gem19) in the same directory where the Ruby interpreter is located."

On my system ruby was installed to /usr/local/bin and gem to /usr/bin.  This seems to confuse IDEA.  (Why it doesn't just use PATH like everyone else, I have no idea.)

Creating a link from /usr/local/bin to the gem in /usr/bin cleared all the problems.

0

Peter,

This is probably the case when Ruby Gem is installed via apt-get on Ubuntu/Debian. This method is slightly controversial for the reasons you've pointed out.

It is far simpler to download the latest RubyGem from source and install that.

I've written an outdated article on installing Ruby Gems.. the same principle applies. Hopefully this is of some use:

  1. cd ~  
  2. mkdir gems && cd gems  
  3. wget http://rubyforge.org/frs/download.php/55066/rubygems-1.3.2.tgz  
  4. tar xf rubygems-1.3.2.tgz  
  5. cd rubygems-1.3.2/  
  6. sudo ruby setup.rb  
  7. sudo ln -s /usr/bin/gem1.8 /usr/bin/gem  
  8. sudo gem update --system  
0

Thank you for the solution.

(Why it doesn't just use PATH like everyone else, I have no idea.)

It's because you may have several ruby interpreters installed in different locations. And you may want to use interpreter which isn't in PATH. Also I prefer RVM for such cases.

RubyMine looks for the scripting gem (gem, or, in case of Ruby 1.9, gem19) in the same directory where the Ruby interpreter is located."

Almost always it is reasonable and right assumption.

0

Hi,
I also have that problem('No Rails found in SDK'), and after read this discussion, I solved it. But then, if I pressed shift+F10, I get this string - in `rescue in load_spec_files': git://github.com/dmitriykotenok/memcache-store-extensions.git (at master) is not checked out. Please run `bundle install` (Bundler::GitError)

But I did 'bundle install'.

0

RubyMine4 still have the issue (while 3rd version did not for me)

I have RVM, jruby via rvm and all the Rails bundled inside the project (mean RAILS_ROOT/vendor/jruby)

From console everything works, but RubyMine cannot see Rails [No Rails found in SDK] (it sees jruby in RVM)

The same with my another bundled project under 1.9.3-p125

Cannot resolve this %(

0

Hello Alexey,

this bug is fixed in the 4.0.2 bugfix update which should be available shortly

0

Thank you for 4.0.2 release, it works perfectly now for MRI/YARV but still does not see Rails bundled with JRuby into /vendor folder (Bundler checkbox is ON in env settings)

setup command is
"bundle install --path=vendor"

result path for the whole bundle is "vendor/jruby" not "vendor/ruby" as for MRI/YARV setups

0

I uninstalled some gems of my projects using "gem uninstall gem_name" outside RubyMine (via Windows command line) and I am facing the same issue.
I am not able to run any project inside RubyMine ... message "No Rails found in SDK" appears.
I am waiting the 4.0.2 bugfix update...

0

I have 4.0.3
and there is the same error
16:36:18 Error running Development: xxx: [No Rails found in SDK]

sorry. all ok

0

The same issue with me on ubuntu and solved with creating link to rails

sudo ln -s /usr/local/bin/rails /usr/bin/rails

Check that rails sdk location is located in the Rubymine ide and in that location must be ref to gem and rails.

I hope this be usefull

0

Thank you!
Your solution helped me and everything works now. Someone should promote your post, if there is such a thing here.

0

I'm still getting this issue with Rubymine 8.0.3. 

I tried remove .rvm and reinstall it and still getting "No Rails found in SDK".

My application runs fine by using command line, just not able to hook up in rubymine. 

 

mbp-0630:avant-basic hzhang82$ which rails

/Users/hzhang82/.rvm/gems/ruby-2.2.2@avant_basic/bin/rails

mbp-0630:avant-basic hzhang82$ which ruby

/Users/hzhang82/.rvm/rubies/ruby-2.2.2/bin/ruby

mbp-0630:avant-basic hzhang82$ which gem

/Users/hzhang82/.rvm/rubies/ruby-2.2.2/bin/gem

mbp-0630:avant-basic hzhang82$ which bundle

/Users/hzhang82/.rvm/gems/ruby-2.2.2@avant_basic/bin/bundle

0

Helen Zhangthis is a known issue, we are working on it. Please see temporary workaround: https://youtrack.jetbrains.com/issue/RUBY-17808#comment=27-1309279

0

Please sign in to leave a comment.