Problems with support for footer tag

I have a partial in my RoR project that is the footer for many of my views (I am using haml).  Nothing very complex but I do use the footer tag.

%footer.f1.container
  %div

The latest version of RubyMine does not like this at all and claims that I need to "define" footer.  The layout is marked with the correct doctype so I would have assumed that RubyMine would be ok with this.  Am I missing something very stupid???

Thank You

3 comments
Comment actions Permalink

Hi,

I think you need to change settings to use HTML5.
see Settings::"Schemas and DTDs"

Hope this help, Oleg.

0
Comment actions Permalink

Yes that was the problem.  As I said it was stupid.  I had made the change for a different project and didn't remember that it was a project setting now a global preference.  Is there a way to make HTML5 the default for the IDE?  I don't see anyplace in the IDE settings.

Thank You

0
Comment actions Permalink

Unfortunately, this is a per-project setting.  There is no way to set it for IDE :(

Regards, Oleg.

0

Please sign in to leave a comment.