scss file does not get syntax highlighting

I have sass plugin enabled but files with .scss extension does not get highlighting at all. I even tried disabling and enabling the plugin, but it does not make any difference.
It does recognize .sass file but I want to use the newer syntax which require .scss extension. Is it supposed to syntax highlight .scss file or is there something I'm doing wrong?

I'm using Rubymine 4.0.3 on Ubuntu 11.04

java version "1.6.0_26"
Java(TM) SE Runtime Environment (build 1.6.0_26-b03)
Java HotSpot(TM) 64-Bit Server VM (build 20.1-b02, mixed mode)


Please make sure that the .scss extension is mapped to the correct file type in Settings | File Types.


ah I found the File Types section under Settings, *.scss file is assinged to text file. I wonder why doesn't it assign *.scss to scss file type by default? maybe because I have disabled the sass plugin before?


It does assign the extension by default if you haven't previously assigned it to another file type.


as far as I know, I never changed the File Types association settings, but I did disable the sass plugin before, then today I created .scss file which does not have syntax highlighting, then I remember to enable the plugin. So maybe I did change it without realizing or maybe disabling the plugin caused that? I don't know, but all is well now :)


Please sign in to leave a comment.