RubyMine not selecting correct gemset?

I'm a licensed user using the latest RubyMine 4.0.3 (117.230).

When I use the terminal, cd to my project directory and run rvm info, I get:

    gemset:       "diablo"

which is what I expect.

In RubyMine when I choose "Show Gem Environment" I see:

  /Users/wwilliam/.rvm/gems/ruby-1.9.2-head@diablo_chrome
   /Users/wwilliam/.rvm/gems/ruby-1.9.2-head@global




My .rvmrc file in the project specifies the "diablo" gemset:

environment_id="ruby-1.9.2-head@diablo"

Now, the "diablo_chrome" gemset was the gemset which was being used previously on this project.

So it appears RubyMine has cached it somewhere, but I can't find any way to force it to change.  I have tried quitting and restarting RubyMine and also closing and re-opening the project.

How can I get RubyMine to change to the correct Gemset?
1 comment
Comment actions Permalink

To answer my own question (somewhat), I found that I could change the gemset in use by selecting the appropriate entry from the "Ruby Interpreter" menu of the "Ruby SDK and Gems" preferences.

However, I would think that would be autoset by honoring the .rvmrc file.  Is this not the case?

0

Please sign in to leave a comment.