can't run debugger under 1.9.3 on Windows 7 64

First of all , what I first did:

I had installed the Ruby dev kit and I had enhanced my ruby 193 installation, the ruby dev kit is in the path. All of this successfully.

I then followed the instructions here:

again, both gems were successfully installed including their native builds.

I then attempted to run a debug session in Rubymine and it complained about a ruby-debug-ide gem not being installed. I accepted and Rubymine proceeded to install that gem but failed with the following error:

        Error running deploy:
Failed to Install Gems. Following gems were not      installed:
C:/Program Files (x86)/JetBrains/RubyMine      112.49/rb/gems/ruby-debug-base19x-0.11.30.pre2.gem: Error installing      ruby-debug-base19x-0.11.30.pre2.gem:
ERROR: Failed to build gem native      extension. C:/Ruby193/bin/ruby.exe extconf.rb Temporarily enhancing PATH      to include DevKit... checking for rb_method_entry_t.body in method.h... no      Building native extensions. This could take a while... checking for      vm_core.h... no      C:/Ruby193/lib/ruby/gems/1.9.1/gems/ruby_core_source-0.1.5/lib/ruby_core_source.rb:39:      Use RbConfig instead of obsolete and deprecated Config. checking for      rb_method_entry_t.body in method.h... no checking for vm_core.h... yes      checking for iseq.h... yes checking for yes checking for yes checking for eval_intern.h... yes creating Makefile      make generating ruby_debug-i386-mingw32.def compiling breakpoint.c      compiling ruby_debug.c ruby_debug.c:28:7: error: conflicting types for      'rb_iseq_compile_with_option'      C:/Ruby193/include/ruby-1.9.1/ruby-1.9.3-p0/vm_core.h:505:7: note:      previous declaration of 'rb_iseq_compile_with_option' was here make: ***      [ruby_debug.o] Error 1 Gem files will remain installed in      C:/Ruby193/lib/ruby/gems/1.9.1/gems/ruby-debug-base19x-0.11.30.pre2 for      inspection. Results logged to      C:/Ruby193/lib/ruby/gems/1.9.1/gems/ruby-debug-base19x-0.11.30.pre2/ext/ruby_debug/gem_make.out     

Any feedback is appreciated.


You can try installing ruby-debug-ide from the command line via gem install ruby-debug-ide --pre


I have the exact same error on Windows 7 64.  I tried the
gem install ruby-debug-ide --pre

which installed but didn't work with RubyMine.


Please try latest EAP, it should handle debug gems installation automatically


Perfect!  That version works.  Thanks.


Where would I find the EAP?  Is this comment still relevant, or has a new version (e.g.: 4.0.3) been released that fixes this issue?


Yes, what does EAP stand for? Never seen that acronym before. I am having problems on Windows 7 x64 too and wondering if this is relevant.


EAP means Early Access Program -- basically you have access to public dev builds (you are using them on your own risk, as sometimes (very rarely though) they can be very unstable and slow, especially first builds of new major version).

You can see links to EAP pages for all products (and more) here:

RubyMine one is here -- (no EAP builds -- current 4.0.3 stable is the latest)


Please sign in to leave a comment.