RM does not 'recognize' gems

I'm new to this, but I spent all day trying to find a solution - with no result.
Running on Ubuntu Lucid 10.04

RM 4.0.3 - updated yesteday:

1.gif
Isssue: when in the editor, it tells me it does not find the gems when hovering over the gem in the 'require' line.

Gems are installed through the RM gem manager, and show as installed, yet I can't seem to use them.
2.gif

Warning in code:
3

Gem env:
4.png

The strange thing is that 'Gems used for 'RubyLego' is empty, but I guess that's because the 'require' cannot resolve them.

I'm stumped - any ides?

4 comments
Comment actions Permalink

Hello Rob,

I've found the problem and fix will be available in the final 4.0.3 release

0
Comment actions Permalink

Hi Dennis - glad to hear! Any idea when the release is scheduled?

Rob.

0
Comment actions Permalink

We're planning to release it this week. BTW, you can add .rb on the end of required file name as a workaround.

0
Comment actions Permalink

Awesome! Thanks for the help.

0

Please sign in to leave a comment.