Ruby mine bundle install doesn't install dependencies

This seems like it should be the most elementary thing, but "install missing gems" doesn't install the dependencies automatically, making the button nearly useless:


/home/bmanica/.rvm/rubies/jruby-1.6.7/bin/jruby /home/bmanica/.rvm/gems/jruby-1.6.7/bin/bundle install
Fetching gem metadata from https://rubygems.org/.JRuby limited openssl loaded. http://jruby.org/openssl
gem install jruby-openssl for full support.
Unfortunately, a fatal error has occurred. Please report this error to the Bundler issue tracker at https://github.com/carlhuda/bundler/issues so that we can fix it. Thanks!
LoadError: OpenSSL::SSL requires the jruby-openssl gem
                         (root) at /home/bmanica/.rvm/rubies/jruby-1.6.7/lib/ruby/site_ruby/shared/jruby/openssl/autoloads/ssl.rb:8
                       use_ssl= at /home/bmanica/.rvm/rubies/jruby-1.6.7/lib/ruby/site_ruby/shared/jruby/openssl/autoloads/ssl.rb:124


Why on earth can't it automatically install the dependent gems?  It works fine from the command line.

(As a loyal IntelliJ user, I have to say that RubyMine could use a little more attention - some of RubyMine's edges are notably rougher than IntelliJ's, which I find disappointing.)

2 comments
Comment actions Permalink

Hello Benson,

I'm not sure how it works for you on the command line, it doesn't work for me with JRuby in the terminal. Moreover, there's official bug in JRuby bugtracker regarding this particular bundle install issue

0
Comment actions Permalink

I found your post when I had the same issue with IntelliJ IDEA 10.5.  I eventually worked around it but couldn't start the development server.

That was when I realized that IDEA was getting confused between my normal ruby install and my jRuby install.  Once I did "rvm remove 1.9.2", everything worked fine.

I'm a complete newbie to rvm / Ruby / jRuby, but I saw something about a default alias that may have been causing the issue?  I honestly have no idea.

>>>>>>>>>  Nathan

0

Please sign in to leave a comment.