Can i open a terminal/shell inside the IDE as a window(like the rails console)?

I remember that this was there in a jetbrains ide before. but i am not sure. anyways this is a very useful feature, because right now i always have to switch between two windows when i want to use the shell. I am running Rubymine 2.0.1 on Ubuntu.

Thanks

12 comments
Comment actions Permalink

Hello yumazutra,

You can configure bash as an external tool in Settings | External Tools.

I remember that this was there in a jetbrains ide before. but i am not
sure. anyways this is a very useful feature, because right now i
always have to switch between two windows when i want to use the
shell. I am running Rubymine 2.0.1 on Ubuntu.


--
Dmitry Jemerov
Development Lead
JetBrains, Inc.
http://www.jetbrains.com/
"Develop with Pleasure!"


0
Comment actions Permalink

Thanks for your quick responce. I can open up a bash shell as a external tool as you said, but this 'shell' lacks functanality(ie: clear doesn't work...etc). However i found this BashSupport plugin(http://plugins.intellij.net/plugin/?idea&id=4230) for the IDE. I think it should offer me what i need. Thanks again for your help.

0
Comment actions Permalink

I think i misunderstood what the plugin does. it is not what i need.


0
Comment actions Permalink

I too am trying to set things up so I can have a full terminal/shell inside RubyMine.  I can run a zsh shell, but things aren't right.  It appears to barf on some of the ANSI coloring things, and other things just don't work right - simple things like "ls" always shows in a single column output (like an "ls -1").  It may be due to the TERM environment variable not being set.  Question is, what should I set it to?  Example:

http://img.skitch.com/20100319-cpidbmqnqt78w9tfm998sg7se1.jpg
What should I set TERM to, or how can I fix this?

0
Comment actions Permalink

Hi there

I too am having an issue with this.  I am running Mac OS X, and am looking to have a Terminal open up in the working directory and operate much like the Terminal in Mac OS X.

How do I configure RubyMine to allow a terminal window to be opened for the current project directory which includes all the standard BASH functionality i.e. it appears that bash is loading but it is not loading the ~/.profile or ~/.bashprofile files.

Matt

0
Comment actions Permalink

Hi there,

Documentation on configuring external tools can be found here: http://www.jetbrains.com/ruby/webhelp/
Also you can propagate your bash settings by implicitly adding --rcfile option to command line.
But note that it won't be a full functional bash anyway.

You can try Native Neighbourhood plugin for better assistance: http://plugins.intellij.net/plugin/?id=38

Regards,

Oleg

0
Comment actions Permalink

Thanks Oleg

I'll try playing around with the Bash settings then, although even with the --rcfile parameter, I am still not seeing a normal bash output which contains the prompt showing me which user I am logged in as and what folder I am in i.e. matthew@mattbookpro~/Projects/test $

I tried the plugin too, but for some reason it won't allow me to use it with RubyMine 2.5 EAP.

Thanks for the advice, but not much luck still.

Matt

0
Comment actions Permalink

Matthew,


I'll try playing around with the Bash settings then, although even with the --rcfile parameter, I am still not seeing a normal bash output which contains the prompt showing me which user I am logged in as and what folder I am in i.e. matthew@mattbookpro~/Projects/test $

This is an expected behavior, because RubyMine works with bash in/out/err threads.

I tried the plugin too, but for some reason it won't allow me to use it with RubyMine 2.5 EAP.

We are going to ask author plugin to mark it compatible with RubyMine.

Regards,
Oleg

0
Comment actions Permalink

The Neighborhood plugin suggested here doesn't give me any embedded console. All it does is provide a more cumbersome way of opening up Terminal than using Spotlight. I've had a fair amount of luck using these settings to set up BASH in Preferences > External Tools (on Mac OS X, but I assume it's the same on Linux, haven't tried that yet):

Program: bash
Parameters: --init-file /Users/daniel/.bashrc -i
Working Directory: $ProjectFileDir$

The -i (interactive shell) option is crucial or you won't get your usual prompt and RVM won't be loaded.

YMMV.

0
Comment actions Permalink

Thanks, Daniel.

This worked, but bash doesn't appear to be fully functional. First, I see this:

bash: no job control in this shell

And when I use a simple "clear" command, I get this:

TERM environment variable not set

Seems like these issues were mentioned in earlier posts, but I'm not sure a solution was offered. Or else I overlooked it. Have you experienced these two issues?

_bryan

0
Comment actions Permalink

Hmm... No, you're right. On closer inspection (been working on a PHP project currently, so I never really gave it a lot of attention) the terminal appears to be pretty faulty to say the least. Not sure where to go from here :( Sorry.

0
Comment actions Permalink

Oh, no worries, Daniel. Just thought I'd put it out there and if you or someone else had something to add, that'd be great. In the meantime, I'm switching to iTerm2 (for Mac OS) as my terminal of choice. Can't run it within RubyMine, but it does allow separate profiles to be set up, each with its own working directory. Seems pretty handy.

Thanks again!

_bryan

0

Please sign in to leave a comment.