Newbie problem creating project

I'm trying to do the Rails tutorial. When I create a new project I get the following error:

C:\RailsInstaller\Ruby1.9.2\bin\ruby.exe -e $stdout.sync=true;$stderr.sync=true;load($0=ARGV.shift) C:\RailsInstaller\Ruby1.9.2\bin/rails _3.1.1_ new C:/Users/Tom/RubymineProjects/first-app --javascript=jquery --skip
C:/RailsInstaller/Ruby1.9.2/lib/ruby/site_ruby/1.9.1/rubygems.rb:314:in `bin_path': can't find gem railties (["3.1.1"]) with executable rails (Gem::GemNotFoundException)
 from C:/RailsInstaller/Ruby1.9.2/bin/rails:19:in `<top (required)>'
 from -e:1:in `load'
 from -e:1:in `<main>'

Process finished with exit code 1




I have done a Quick gem install of "railties" and it appears to be successful. But I still get this error!

I'm running off the RailsInstaller 1.9.2. At command line if I type "bundle install" it shows "railties" as being installed.

p.s. On a side note, how do I run bundle commands not listed in RubyMine? Like "bundle show"
1 comment
Comment actions Permalink

Hi My Friend,

try this commands:
gem update
gem update --system
gem cleanup

the problem must be solved! (tested by myself)

i think it supports "bundle show".

Best Regards,
Saeed

0

Please sign in to leave a comment.