EAP 112.669 Problem with Rspec

I get the following when trying to run specs:  "gem_original_require': no such file to load -- teamcity/spec/runner/formatter/teamcity/formatter (LoadError)"

I do not get the problem when runn EAP 112.477.  I think this problem occurred years ago, and may have reared its ugly head, again.

Have a good one.  Love your product.

dvn

5 comments
Comment actions Permalink

Would like to add that I'm seeing this same error with RM-112.477 also.

In my case the error seems related to Spork.   Spork server is reporting that it's being told to run with "Spec::Runner::Formatter::TeamcityFormatter" with command line require when Rake spec task is run by RubyMine.  

If I remove --drb from .rspec file, the error goes away.

0
Comment actions Permalink

I have no issues with doing Rspec with 113.2

0
Comment actions Permalink

Hm, I just downloaded 113.2 and tried, the problem is still there.

Just to be clear, the problem occurs when rspec is run from RubyMine (i.e. trying to debug a spec) and you are using Spork.

This means my .rspec contains --drb, and if .rspec contains --drb,  RubyMine passes the following to RSpec:


["--color", "--backtrace", "--format", "Spec::Runner::Formatter::TeamcityFormatter", "--require", "teamcity/spec/runner/formatter/teamcity/formatter", "./spec/models/fileone_spec.rb", "./spec/models/filetwo_desc_spec.rb"]...

I don't have the formatter, so rspec fails.  

This happens even if Spork Drb server isn't running and local mode is forced.  As long as --drb is in .rspec file, RubyMine seems to want to use TeamcityFormatter.


Workaround is to remove --drb from .rspec when you want to debug a spec.  Put it back in to continue happily with Spork.  

May be this isn't exactly the same problem OP was reporting, but seems to be in the vicinity....
0
Comment actions Permalink

Aki,

How do you launch spork server? Do you use RubyMine's "Tools|Run Spork Drb Server..." action?

0
Comment actions Permalink

Roman, I was running Spork from a command line shell.

Not quite understanding why having --drb in .rspec causes this difference, but does this mean you can only run rake test tasks against RubyMine launched Spork server and not externally launch spork?

0

Please sign in to leave a comment.