Rspec : Bundler option disabled

Answered

Hi,

Could anyone help me with the following issue I have with RubyMine 3.2.4 ?
In Run > Edit Configurations > Rspec > Bundler tab , the option "Run script in context of the bundle (bundle exec)" is always disabled. I cannot check it.

The resulting problem is that my specs are not run with the gems specified in the Gemfile.

I tried to :
- Run RubyMine as root user
- Remove the .idea folder
- Reset the RubyMine configuration by removing the conf directory .RubyMine32 from my home folder
- Reinstall RubyMine 3.2.4

None of these worked. So if anyone has a solution, I'll be glad to hear it.
Thank you,

5 comments
Comment actions Permalink

Please try updating to the latest 4.0 EAP and see if the problem persists.

0
Comment actions Permalink

Hi Dennis,

I updated my RubyMine version to 4.0 EAP. Unfortunately, the problem remains the same.
Maybe it's a problem in a conf file out of RubyMine folder?

0
Comment actions Permalink

Please provide output of Tools | Show Gem Environment

0
Comment actions Permalink

I did Tools -> Bundler -> Install

seems RubyMine required it's own copy of bundler.(Install was the only available option)

0
Comment actions Permalink

@Andrii,

the current behaviour will be improved in 2019.1 version:

https://youtrack.jetbrains.com/issue/RUBY-21929

0

Please sign in to leave a comment.