rubymine insert spaces unintentionally

When I'm just browsing a file and don't intend to edit it, often Rubymine insert spaces. I think this happen when there is no spaces on empty lines, rubymine might added the space to match indentation when the cursor moves over that line. Is there a way to turn off this auto inserting of spaces?

Here is an example, dot (.) represents white space here

if something


..# do this
end

becomes


if something
..
..# do this
end


I think this happens when I move my cursor on the empty line using End and then Right arrow

4 comments
Comment actions Permalink

You can disable this behaviour by unchecking Settings | Editor | Virtual Space | Allow Placement of caret after end of line

0
Comment actions Permalink

I already have that setting turned off.
It insert spaces not when I start typing, just when navigating the cursor (using End and Right arrow). Seems like a bug, no?

0

Please sign in to leave a comment.