RubyMine consumes 100%+ of the CPU

When I run RubyMine I am seeing it consume a horrendous amount of CPU.  The Activity Monitor on my MacBook shows anywhere from 90% to 300% of the CPU.  I suspect that it is indexing but I do not see any explicit indication of that.  I have tried excluding the logs folder from the Project Structure, but that did not help.

Is there any way to disable indexing altogether?  RubyMine atm is completely unusable!

-Paul Deuter

5 comments
Comment actions Permalink

The RubyMine log shows lots of entries like this:
2011-11-09 10:13:20,274 [1298325]   INFO - ls.structure.data.Declarations - Creating declaration pointer to a non-stub-based element Dot reference

several of these every millisecond ...

is that normal?

-Paul

0
Comment actions Permalink

Paul, are you using RubyMine 4 EAP? We have fixed several processor leaks and fixes will be available in the next EAP build

0
Comment actions Permalink

I am using RubyMine 3.2.4.

What I am experiencing is not a normal performance problem but rather something totally abnormal.  Perhaps I need to simply reinstall?  
Are there instructions for wiping out the RubyMine folders and reinstalling froms scratch?

Thanks,
Paul

0
Comment actions Permalink

I think I repaired my installation.  I took the following steps:

1.  I killed the RubyMine process.
2.  I deleted the RubyMine app from the applications folder.
3.  I ran these commands:

rm -rf ~/Library/Caches/RubyMine32
rm -rf ~/Library/Logs/RubyMine32

4.  I deleted the .idea folder from my project directory

5.  I deleted all the large log files (because RubyMine will start trying to index these as soon as you open a directory without giving you time to "exclude" them)
6.  Then I reinstalled RubyMine from the dmg file.
7.  I reopend my project folder
8.  I quickly went to 'Preferences' -> 'Project Structure' and excluded the log directory, etc.

Now RubyMine is behaving much better.  I think there needs to be a button to wipe out the index and re-index.  It seems that if the index gets corrupted, then it may start thrashing.

-Paul

0
Comment actions Permalink

Actually there is an action for that: File | Invalidate Caches

0

Please sign in to leave a comment.