Support for rubygems proxy in Mine ?

Hi,

I am using a local rubygems proxy, like this:

  http://blog.sprout-technology.com/setting-up-rubygems-proxy-on-local-server/

Which generally works from the command line, but does not seem to fully work with Rubymine.

I get the "stack level too deep" error, see attached.

I presume this is more of an issue with the proxy not fully supporting the rubygems interface, but thought I'd see if there were any clues from the Rubymine side.

This Rubygem proxy issue is raised here, although it seems to be a different error back then:

  https://github.com/fnando/rubygems_proxy/issues/4

So, is there logging of the rubygems process and/or a debug I can turn to get more information?

Thanks,
Chris



Attachment(s):
Screen shot 2011-09-05 at 06.45.33.png
9 comments
Comment actions Permalink

> I get the "stack level too deep" error, see attached.
Such error occurs in RubyMine when you are using old RubyGems version, please update it (gem update --system)

0
Comment actions Permalink

Hi Roman,

Thanks - I had done a search earlier and saw comments relating to this error and so updated rubygems. I updated to 1.8.10.  I have since restarted Rubymine, but it still gives the error.

I am using Mine 3.2.3, running on OSX 10.6.8.

I am using rvm 1.8.0, and assuming Mine honours the .rvmrc settings relating to gem...

Thanks,
Chris

0
Comment actions Permalink

I am using rvm 1.8.0, and assuming Mine honours the .rvmrc settings relating to gem...

Yes, RubyMine doesn't exec .rvmrc. Which gem related settings do yo have there?

0
Comment actions Permalink

rvm use 1.9.2@p-project

So, specific ruby flavour/version and gemset.

I thought Rubymine was rvm/gemset aware - is that just for the project, but not loading gems?

So, do I need to get the latest version of Rubygems for the system Ruby, default gemset?

Thanks,
Chris

0
Comment actions Permalink

I thought Rubymine was rvm/gemset aware - is that just for the project, but not loading gems?

On project open RubyMine parses .rvmrc file and tries to set another project ruby sdk if needed. You can manually change SDK in RubyMine | Preferences | Ruby SDK and Gems Manager Dialog

0
Comment actions Permalink

Oh - any plans to improve this support, is there an open ticket for it?

Should I raise one?

Thanks,
Chris

0
Comment actions Permalink

Oh - any plans to improve this support, is there an open ticket for it?

Which kinds of improvements do you want?

I am using a local rubygems proxy, like this:

  http://blog.sprout-technology.com/setting-up-rubygems-proxy-on-local-server/

Which generally works from the command line, but does not seem to fully work with Rubymine.

Have you succeeded with it in RubyMine?

0
Comment actions Permalink

Hi,

Roman.Chernyatchik wrote:


Which kinds of improvements do you want?

Would be good if Rubymine was able to correctly use the .rvmrc more regularly - seems to be using the wrong ruby/gemset sometimes - will try and notice when it gets it wrong and raise a bug for it.

Just downloaded 3.2.4.


I am using a local rubygems proxy, like this:

  http://blog.sprout-technology.com/setting-up-rubygems-proxy-on-local-server/

Which generally works from the command line, but does not seem to fully work with Rubymine.

Have you succeeded with it in RubyMine?

I will try again - making sure that the correct rvm ruby/gemset is in use first.

Thanks,

Chris

0
Comment actions Permalink

Bug raised:

"When using .rvmrc with specific Ruby and gemset, sometimes RubyMine is selecting wrong Ruby version"

http://youtrack.jetbrains.net/issue/RUBY-9373?projectKey=RUBY&query=rvm+wrong+ruby

Chris

0

Please sign in to leave a comment.