Unable to change Subversion Setting

For some reason when I go to file->settings->VCSs->Subversion, all I get is a loading window and the setting never load. All other types of source control load fine but Subversion does not. I'm running 3.2.3 on Ubuntu 11. Any help would be appreciated. Thanks

2 comments
Comment actions Permalink

I'm seeing the same issue. It seems like a bug. I get the following stack track whenever I open the SVN options for the first time after starting RM. Could you check if you get the same stack trace?

Java HotSpot(TM) 64-Bit Server VM (build 20.1-b02, mixed mode)
[1501018]  ERROR - plication.impl.ApplicationImpl - java.lang.Long cannot be cast to java.lang.Double
java.lang.ClassCastException: java.lang.Long cannot be cast to java.lang.Double
    at java.lang.Double.compareTo(Double.java:32)
    at javax.swing.SpinnerNumberModel.incrValue(SpinnerNumberModel.java:332)
    at javax.swing.SpinnerNumberModel.getPreviousValue(SpinnerNumberModel.java:371)
    at javax.swing.plaf.basic.BasicSpinnerUI.updateEnabledState(BasicSpinnerUI.java:489)
    at javax.swing.plaf.basic.BasicSpinnerUI.updateEnabledState(BasicSpinnerUI.java:470)
    at javax.swing.plaf.basic.BasicSpinnerUI.access$200(BasicSpinnerUI.java:33)
    at javax.swing.plaf.basic.BasicSpinnerUI$Handler.stateChanged(BasicSpinnerUI.java:1047)
    at javax.swing.JSpinner.fireStateChanged(JSpinner.java:434)
    at javax.swing.JSpinner$ModelListener.stateChanged(JSpinner.java:361)
    at javax.swing.AbstractSpinnerModel.fireStateChanged(AbstractSpinnerModel.java:102)
    at javax.swing.SpinnerNumberModel.setValue(SpinnerNumberModel.java:430)
    at javax.swing.JSpinner.setValue(JSpinner.java:329)
    at org.jetbrains.idea.svn.SvnConfigurable.reset(SvnConfigurable.java:256)
    at com.intellij.openapi.vcs.configurable.VcsManagerConfigurable$4.reset(VcsManagerConfigurable.java:214)
    at com.intellij.openapi.options.newEditor.OptionsEditor.b(OptionsEditor.java:400)
    at com.intellij.openapi.options.newEditor.OptionsEditor.access$2200(OptionsEditor.java:66)
    at com.intellij.openapi.options.newEditor.OptionsEditor$6$1$1.run(OptionsEditor.java:368)
    at com.intellij.openapi.application.impl.ApplicationImpl.runEdtSafeAction(ApplicationImpl.java:971)
    at com.intellij.openapi.options.newEditor.OptionsEditor$6$1.run(OptionsEditor.java:362)
    at com.intellij.openapi.application.impl.ApplicationImpl.runReadAction(ApplicationImpl.java:774)
    at com.intellij.openapi.options.newEditor.OptionsEditor$6.run(OptionsEditor.java:360)
    at com.intellij.openapi.application.impl.ApplicationImpl$6.run(ApplicationImpl.java:375)
    at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:441)
    at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:303)
    at java.util.concurrent.FutureTask.run(FutureTask.java:138)
    at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886)
    at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908)
    at java.lang.Thread.run(Thread.java:662)
    at com.intellij.openapi.application.impl.ApplicationImpl$1$1.run(ApplicationImpl.java:130)
[1501020]  ERROR - plication.impl.ApplicationImpl - JetBrains RubyMine 3.2.3  Build #RM-107.494
[1501020]  ERROR - plication.impl.ApplicationImpl - JDK: 1.6.0_26
[1501020]  ERROR - plication.impl.ApplicationImpl - VM: Java HotSpot(TM) 64-Bit Server VM
[1501021]  ERROR - plication.impl.ApplicationImpl - Vendor: Sun Microsystems Inc.
[1501021]  ERROR - plication.impl.ApplicationImpl - OS: Linux
[1501021]  ERROR - plication.impl.ApplicationImpl - Last Action: ShowSettings
0
Comment actions Permalink

I opened a ticket at

http://youtrack.jetbrains.net/issue/RUBY-9282

Add your info there if it matches, please :)

0

Please sign in to leave a comment.