RM 3.2.1 - SPORK / CUCUMBER Errors Exception encountered: #<LoadError: no such file to load -- teamcity/cucumber/formatter

Hi

I was looking forward to the new Version of RubyMine, I am playing around, but again,
I cannot work productive.
Unfortunately its again broken to test with spork, cucumber.
I would be very thankful for a fast solution.

Testing without spork... is an absolute no-go.

Tests
a) Spork Cucumber is working on console
b) Cucumber in RM is working without Spork running
c) Rspec with Spork is working in RM

here my setup:

RubyMine 3.2.1

Rails 3.1 RC4
Spork 0.9.0.rc4
cucumber 1.0.0
cucumber-rails 1.0.2

Error Message:


.rvm/rubies/ruby-1.9.2-p180-patched/bin/ruby -e $stdout.sync=true;$stderr.sync=true;load($0=ARGV.shift) /Users/rafael/Sites/myApp/script/cucumber /Users/rafael/Sites/myApp/features --expand --drb --color
Testing started at 09:09 ...
Using the default profile...
Disabling profiles...
Exception encountered: #<LoadError: no such file to load -- teamcity/cucumber/formatter
Error creating formatter: Teamcity::Cucumber::Formatter>
backtrace:



Has anybody a solution? Thanks a lot!

5 comments
Comment actions Permalink

Is spork drb server is launched using RubyMine? (Tools | Run Spork Drb Server...)

0
Comment actions Permalink

Yes. Absolutely . Spork generated, bootstraped and started from Menu > Tools
I even started a fresh project, I took yours too, none of them are working with spork and cucumber.
I also tried to install with fresh cucumber install
    rails g cucumber:install

Nothing helped.

I tried with and without flag -r features.
I get it running with --format pretty (only for testing) purpose, but tests are then not visible in the GUI, only in the log oviously.

Does this help you? Tell me, if you need more information for bug hunting.

greez

0
Comment actions Permalink

Be sure to delete all old scripts, which launches spork and tests and generate them from scratch.
Somehow, old Path Variables may not be overwritten by RubyMine, after having upgraded.
In my case it was the upgrade 3.1.1. -> 3.2.1

I had still 3.1.1 in my RUBYLIB Variable in the spork launch script.

Hope that helps others, it took me many hours to figure that out.

0
Comment actions Permalink

Where are these spork scripts located in RubyMine?

0
Comment actions Permalink

Open Run | Edit Configurations dialog, and in "Ruby" section find smth like "RSpec: Spork DRb server". You can just delete it and then "Tools | Run Spork Drb Server..." will recreate correct versions.

0

Please sign in to leave a comment.